summaryrefslogtreecommitdiff
path: root/media-sound/cmusfm/cmusfm-0.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/cmusfm/cmusfm-0.4.1.ebuild')
-rw-r--r--media-sound/cmusfm/cmusfm-0.4.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/cmusfm/cmusfm-0.4.1.ebuild b/media-sound/cmusfm/cmusfm-0.4.1.ebuild
new file mode 100644
index 000000000000..b2cac96f9c33
--- /dev/null
+++ b/media-sound/cmusfm/cmusfm-0.4.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools readme.gentoo-r1
+
+DESCRIPTION="Last.fm scrobbler for cmus music player"
+HOMEPAGE="https://github.com/Arkq/cmusfm"
+SRC_URI="https://github.com/Arkq/cmusfm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+DEPEND="
+ net-misc/curl
+ dev-libs/openssl:0=
+ libnotify? ( x11-libs/libnotify )
+"
+RDEPEND="
+ ${DEPEND}
+ media-sound/cmus
+"
+BDEPEND="virtual/pkgconfig"
+
+DOC_CONTENTS="Please refer to the README.md file before running cmusfm the first time."
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable libnotify)
+}
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_pkg_postinst
+}