summaryrefslogtreecommitdiff
path: root/media-sound/bpmdetect/bpmdetect-0.7.0_pre20170810-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/bpmdetect/bpmdetect-0.7.0_pre20170810-r1.ebuild')
-rw-r--r--media-sound/bpmdetect/bpmdetect-0.7.0_pre20170810-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-sound/bpmdetect/bpmdetect-0.7.0_pre20170810-r1.ebuild b/media-sound/bpmdetect/bpmdetect-0.7.0_pre20170810-r1.ebuild
new file mode 100644
index 000000000000..529bd2033449
--- /dev/null
+++ b/media-sound/bpmdetect/bpmdetect-0.7.0_pre20170810-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT=b13aac15904c1f821b1739d00445f49432705387
+inherit cmake
+
+DESCRIPTION="Automatic BPM detection utility"
+HOMEPAGE="https://github.com/Tatsh/bpmdetect"
+SRC_URI="https://github.com/Tatsh/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtwidgets:5
+ media-libs/flac:=
+ media-libs/libmad
+ media-libs/libvorbis
+ media-libs/portaudio
+ media-libs/taglib
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc-11.patch )
+
+src_install() {
+ einstalldocs
+ dobin "${BUILD_DIR}"/src/${PN}
+}