summaryrefslogtreecommitdiff
path: root/media-sound/a2jmidid/a2jmidid-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/a2jmidid/a2jmidid-9999.ebuild')
-rw-r--r--media-sound/a2jmidid/a2jmidid-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-sound/a2jmidid/a2jmidid-9999.ebuild b/media-sound/a2jmidid/a2jmidid-9999.ebuild
new file mode 100644
index 000000000000..c3d3a8ed15a2
--- /dev/null
+++ b/media-sound/a2jmidid/a2jmidid-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson git-r3
+
+DESCRIPTION="Daemon for exposing legacy ALSA sequencer applications in JACK MIDI system"
+HOMEPAGE="https://github.com/linuxaudio/a2jmidid"
+EGIT_REPO_URI="https://github.com/linuxaudio/a2jmidid.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="dbus"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+CDEPEND="
+ ${PYTHON_DEPS}
+ media-libs/alsa-lib
+ virtual/jack
+ dbus? ( sys-apps/dbus )
+"
+RDEPEND="${CDEPEND}"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst README.rst internals.txt )
+
+src_configure() {
+ local emasonargs=(
+ -Ddisable-dbus=$(usex dbus false true)
+ )
+
+ meson_src_configure
+}