summaryrefslogtreecommitdiff
path: root/media-radio/tqsl/tqsl-2.6.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/tqsl/tqsl-2.6.4.ebuild')
-rw-r--r--media-radio/tqsl/tqsl-2.6.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-radio/tqsl/tqsl-2.6.4.ebuild b/media-radio/tqsl/tqsl-2.6.4.ebuild
new file mode 100644
index 000000000000..ee19a35410f7
--- /dev/null
+++ b/media-radio/tqsl/tqsl-2.6.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+inherit cmake wxwidgets
+
+DESCRIPTION="ARRL Logbook of the World"
+HOMEPAGE="https://www.arrl.org/tqsl-download"
+SRC_URI="https://www.arrl.org/${PN}/${P}.tar.gz"
+
+LICENSE="LOTW"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/expat:=
+ dev-libs/openssl:0=
+ net-misc/curl:=
+ dev-db/lmdb:=
+ sys-libs/zlib:=
+ x11-libs/wxGTK:${WX_GTK_VER}="
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS.txt INSTALL README )
+HTML_DOCS=( html/. )
+
+src_configure() {
+ setup-wxwidgets
+ cmake_src_configure
+}