summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-fritzbox
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/vdr-fritzbox')
-rw-r--r--media-plugins/vdr-fritzbox/Manifest2
-rw-r--r--media-plugins/vdr-fritzbox/files/vdr-fritzbox-1.5.3-boost-1.67.patch22
-rw-r--r--media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r1.ebuild34
3 files changed, 58 insertions, 0 deletions
diff --git a/media-plugins/vdr-fritzbox/Manifest b/media-plugins/vdr-fritzbox/Manifest
index 57e087ec6c3d..c7a180802557 100644
--- a/media-plugins/vdr-fritzbox/Manifest
+++ b/media-plugins/vdr-fritzbox/Manifest
@@ -1,3 +1,5 @@
+AUX vdr-fritzbox-1.5.3-boost-1.67.patch 597 BLAKE2B 8efc4aa1ff4418bf9d627032a89d3975d264446266f92a823ccf467dfa8a593ff3c99768e9ae3a8421fb9bfc72145ec5b114997c4f653f5fc786cff45375d13c SHA512 97ab8e2e572be18dea596a6b66eae5d1929c7178bc5027abd6035240fab0fa76afe26170007e7c84776f11d4c452fa39fc8140a21adcba5eb78912984809098a
DIST vdr-fritzbox-1.5.3.tgz 132207 BLAKE2B c9a93e922eeb2126279409e3948c44cb1fc3348d44fbcc2c1116038d66fc77a707d3885a6d587c8996138fcaff134bb78db4dab2d122caf0293d2d8d8770e985 SHA512 d396bb1386ffc4b53867c735d4ffc710c4266067e011e17f2d4aa597ecceeb502d2c6e23a1df69f929503b2cd5d07f4d57869c890040b1ae9af1742c044541be
+EBUILD vdr-fritzbox-1.5.3-r1.ebuild 1005 BLAKE2B 6aab7bf9f70f0ca7d88711e4f391824131ac0a9582d84cebf06dccb44cfe904f545b3c3c7c6452fceee88d7dd509c9fadc32a6193b5c3cf5c0832ddb9b2ddceb SHA512 ce345543bc5c04245858badd208607ba4529746221789a1746554611af724db52588f50249ec0ec7530f4e8c271a4c3b7363bd0bca82e306f513ce771ab7520a
EBUILD vdr-fritzbox-1.5.3.ebuild 968 BLAKE2B 2e8313392be56bafbf092c188c344db693cc0679432b02466fdd7c31cc1f36c44e3f31ee065e240ad85d1bf8f61c7a42d0fe46cbeef9083042019aaa5cf15b60 SHA512 182f0f127cb3982a70f0d88143dee964b554e43a485a8acb51d60099fce64e73158d8701385cbae94172e8b64fc2b704b90d8f10eccad31ab91ebf8bfed2e9cb
MISC metadata.xml 330 BLAKE2B 6f2fc336e9406fcc2413210e07d2396d1fe4faff1e8be1ae7d16428e5df9c46f7c00b2f183fb9e6e973014e6ce46379d12774e3597f3caf901f812f5c90b5360 SHA512 b0521cb557fc56b09d61f9dded16f511d306151642b7a45cb243132d216531459d519a5abd9b38c23c7799b03bbaea8f8e2122a9b28ae200940fdc8a194cf0f5
diff --git a/media-plugins/vdr-fritzbox/files/vdr-fritzbox-1.5.3-boost-1.67.patch b/media-plugins/vdr-fritzbox/files/vdr-fritzbox-1.5.3-boost-1.67.patch
new file mode 100644
index 000000000000..f57338782795
--- /dev/null
+++ b/media-plugins/vdr-fritzbox/files/vdr-fritzbox-1.5.3-boost-1.67.patch
@@ -0,0 +1,22 @@
+From 212847f0efaeffee8422059b8e202d844174aaf3 Mon Sep 17 00:00:00 2001
+From: Joachim Wilke <github.com@joachim-wilke.de>
+Date: Thu, 28 Jun 2018 12:56:54 +0200
+Subject: [PATCH] Add compatibility with boost 1.67
+
+Refers to https://github.com/jowi24/vdr-fritz/issues/1
+---
+ TcpClient.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/TcpClient.cpp b/TcpClient.cpp
+index b9b38e9..c6cc08e 100644
+--- a/libnet++/TcpClient.cpp
++++ b/libnet++/TcpClient.cpp
+@@ -19,6 +19,7 @@
+ *
+ */
+
++#define BOOST_ASIO_USE_BOOST_DATE_TIME_FOR_SOCKET_IOSTREAM
+ #include "TcpClient.h"
+
+ #include <liblog++/Log.h>
diff --git a/media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r1.ebuild b/media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r1.ebuild
new file mode 100644
index 000000000000..eaa4abe5e236
--- /dev/null
+++ b/media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: Inform about incoming phone-calls and use the fritz!box phonebook"
+HOMEPAGE="https://github.com/jowi24/vdr-fritz"
+SRC_URI="https://github.com/jowi24/vdr-fritz/releases/download/1.5.3/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0
+ dev-libs/boost[threads]
+ >=media-video/vdr-1.7.34
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-boost-1.67.patch" )
+
+pkg_postinst() {
+ elog "It is recommend to update your firmware release to the latest."
+ elog
+ elog "The integrated call monitor (available in Fritz!Box official"
+ elog "firmware releases >= *.04.29) has to be enabled in order to"
+ elog "have the vdr-fritzbox plugin display anything on your tv. To"
+ elog "enable it call #96*5* from your telephone. If that doesn't"
+ elog "work for you, read the documentation for further instructions."
+}