summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-epgsync
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/vdr-epgsync')
-rw-r--r--media-plugins/vdr-epgsync/Manifest1
-rw-r--r--media-plugins/vdr-epgsync/files/vdr-epgsync-1.0.1_vdr-2.4.patch56
2 files changed, 0 insertions, 57 deletions
diff --git a/media-plugins/vdr-epgsync/Manifest b/media-plugins/vdr-epgsync/Manifest
index 09d561b8006b..e947b0ab9a40 100644
--- a/media-plugins/vdr-epgsync/Manifest
+++ b/media-plugins/vdr-epgsync/Manifest
@@ -1,4 +1,3 @@
-AUX vdr-epgsync-1.0.1_vdr-2.4.patch 2244 BLAKE2B 76f1a631d4bdc0c86121b96ac23d08c3b691c0152a6238e392a9308b0220e9cf7acd04ffa23fcb7d509191f0d9ab31ddc6e64acf603ca491ae459ad1f6ce34f6 SHA512 0e8558222090dc2248c7c96798523a69988738a4e28d0aed24f93a4b8eb197d220227896fa364ccf5c029666164a4a2a51876794d53c0a6e8c4bee9f89d3f4f5
DIST vdr-epgsync-1.0.1.tgz 18198 BLAKE2B 0c2d782253d9c48a59e2dcf8cb58295b92d5c8b9384d947659b760c1f6b68c9b63c10ca4bccf5ae767d7499ea934f321edd4cc9c600f8da746781bc3a050b84d SHA512 1c9d1220460031a7dd22f8a8131c291bf9c66847be33c2a57464c29d7ed4b2297d6bda04c3ea0a24e3f00d5afe040d9236c5f9ef9f4389878906abc54466de18
DIST vdr-epgsync-1.0.2.tar.gz 18108 BLAKE2B 75d22b63afb7b09d8f3ffd25fd977182f4c1c204582c50848319addcbdb30c15e6b8a02fbb9e9e23efa8bf9686c1ea398fdf5046704abf4b1bb846d5c6574045 SHA512 926d4a00a8475b01b3fda37b3ca075985a828f29a9801a9978bccf02d28953f5c5d0ada41ed318044fc0bf75ddf671de69bb373e82c1676a99c18a3f024e1620
EBUILD vdr-epgsync-1.0.1.ebuild 452 BLAKE2B fcb4b6fe199626e24325efc3d0d2faada9bcc0c754285082f240c8d86222074d6c1e02300c913ed46d03190aa7138f9f489c30bfaf94deb0a6a8dd58fda0ba66 SHA512 36def56f8c200017cf099ab056735c49a94a9368f9c9a4ed95c238e51fc673d4bb8f268c56b13269f95ee76a7fbf4299b88bbf1f4883cdde2e633b73f6739b38
diff --git a/media-plugins/vdr-epgsync/files/vdr-epgsync-1.0.1_vdr-2.4.patch b/media-plugins/vdr-epgsync/files/vdr-epgsync-1.0.1_vdr-2.4.patch
deleted file mode 100644
index 9b3df4097fd4..000000000000
--- a/media-plugins/vdr-epgsync/files/vdr-epgsync-1.0.1_vdr-2.4.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-compilefix for media-video/vdr-2.4.1
-Suggested-by: MatthiasK @ vdr-portal.de
-
-Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org> ( 27 Dec 2019 )
-diff -Naur epgsync-1.0.1.orig/thread.c epgsync-1.0.1/thread.c
---- epgsync-1.0.1.orig/thread.c 2019-12-26 00:12:49.124492713 +0100
-+++ epgsync-1.0.1/thread.c 2019-12-26 00:17:55.129492713 +0100
-@@ -42,9 +42,10 @@
- }
- }
-
--cChannel *GetChannelByName(const char* Name, const cChannel *IgnoreChannel = NULL, eChannelTypes Type = ctAll)
-+const cChannel *GetChannelByName(const char* Name, const cChannel *IgnoreChannel = NULL, eChannelTypes Type = ctAll)
- {
-- for (cChannel *channel = Channels.First(); channel; channel = Channels.Next(channel)) {
-+ LOCK_CHANNELS_READ;
-+ for (const cChannel *channel = Channels->First(); channel; channel = Channels->Next(channel)) {
- if (strcasecmp(Name, channel->Name()) == 0 || strcasecmp(Name, channel->ShortName()) == 0) {
- if (IsType(channel, Type) && channel != IgnoreChannel)
- return channel;
-@@ -95,20 +96,17 @@
- if (EpgSyncSetup.redirectChannels == rcmId) {
- // Direct import, no mapping:
- // loop through local channels, get channels by ID
-- cSchedulesLock *lock = NULL;
-- for (cChannel *channel = Channels.First(); channel && Running();
-- channel = Channels.Next(channel)) {
-- if (!lock)
-- lock = new cSchedulesLock();
-- if (cSchedules::Schedules(*lock)->GetSchedule(channel)) {
-- DELETENULL(lock);
-+ LOCK_CHANNELS_READ;
-+ for (const cChannel *channel = Channels->First(); channel && Running();
-+ channel = Channels->Next(channel)) {
-+ LOCK_SCHEDULES_READ;
-+ if (Schedules->GetSchedule(channel)) {
- if (CmdLSTE(f, *channel->GetChannelID().ToString())) {
- AddSchedule(f);
- }
- cCondWait::SleepMs(EPGSYNC_SLEEPMS);
- }
- }
-- DELETENULL(lock);
- }
- else {
- // Map channels by name:
-@@ -182,7 +180,8 @@
- targetChannel = NULL;
-
- const char* p = skipspace(s + 1);
-- cChannel *c = Channels.GetByChannelID(tChannelID::FromString(p));
-+ LOCK_CHANNELS_READ;
-+ const cChannel *c = Channels->GetByChannelID(tChannelID::FromString(p));
- bool cOk = IsType(c, (eChannelTypes) EpgSyncSetup.channelTypes);
-
- if (cOk && EpgSyncSetup.redirectChannels != rcmNameId) {