summaryrefslogtreecommitdiff
path: root/media-plugins/noise-repellent/noise-repellent-0.1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/noise-repellent/noise-repellent-0.1.5.ebuild')
-rw-r--r--media-plugins/noise-repellent/noise-repellent-0.1.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-plugins/noise-repellent/noise-repellent-0.1.5.ebuild b/media-plugins/noise-repellent/noise-repellent-0.1.5.ebuild
new file mode 100644
index 000000000000..528e355dc08e
--- /dev/null
+++ b/media-plugins/noise-repellent/noise-repellent-0.1.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="An lv2 plug-in for broadband noise reduction"
+HOMEPAGE="https://github.com/lucianodato/noise-repellent"
+SRC_URI="https://github.com/lucianodato/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ media-libs/lv2
+"
+RDEPEND="
+ sci-libs/fftw:3.0
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ --prefix="${EPREFIX}/usr/$(get_libdir)/lv2"
+ )
+ meson_src_configure
+}