summaryrefslogtreecommitdiff
path: root/media-plugins/mythplugins
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/mythplugins')
-rw-r--r--media-plugins/mythplugins/Manifest2
-rw-r--r--media-plugins/mythplugins/mythplugins-31.0_p20210731.ebuild166
2 files changed, 168 insertions, 0 deletions
diff --git a/media-plugins/mythplugins/Manifest b/media-plugins/mythplugins/Manifest
index 56ccaa5d8ad1..a739ee9e8d1a 100644
--- a/media-plugins/mythplugins/Manifest
+++ b/media-plugins/mythplugins/Manifest
@@ -1,3 +1,5 @@
DIST mythplugins-31.0.tar.gz 102552136 BLAKE2B b09b41230eb2cae19d770c3cc59151863e0a56e95a86627473d52613e62f0acf3bd0c4bb37afb340ab874c222899f9d3c219ded470785d27960db9b39d784ceb SHA512 d53817231409934ef37d12739c38cf6936f04f816b0ba1c9738ce99b5b4ff387c70b683ccd84f649ff2f74992b2158829f5f1d1ffe06c8768da1922b90439f6e
+DIST mythplugins-31.0_p20210731.tar.gz 102637029 BLAKE2B 0ca6124d20d428c8b9999813c819c01a97c4806fbd2f70f5b50d698c5f9c3cafd3141ee1379b2b63510705e2083109d91362c3fcc6277f58d461f2138d1604fd SHA512 e262ce91fd8a523daa772d13675ff6639f95202f66be67b2a405e9ea9204d6663128621c5142752f2a889e25cbc8be6d92b3759508767e94207326343a91f092
EBUILD mythplugins-31.0-r1.ebuild 4062 BLAKE2B 7c511a8eebd9dd6584a0dfcf1c3f2bcf6982f32aed529f5d786d50b503c4427fec73078c009572567bebdf092fb5dcce1f32bcc73db8e568d52026094f3f25b5 SHA512 96be78aaa73b20d7a78a775773e333b168c230e34491983d8205d70d512da93b295c279ce21ed61a9a04ad9040003713470fcd80dfa0d8a32e085b43e6596494
+EBUILD mythplugins-31.0_p20210731.ebuild 4294 BLAKE2B ff084db9d8e25e44347906860c15f98ad4fae0d5dbb5ace116a6ea25637c2d31c1527174d93465e73999d23cb5c47ab9599e1c4b12ca9a6ea3d0a314d0b1ee19 SHA512 b845f1c64df67df5bd287673c4148bacf3d7e8ee731d59dc0efb384f589a5ac25261fa08b8da77a06cae17cf77c88fb918430d5ae501b11aff57f665982d2035
MISC metadata.xml 1609 BLAKE2B 879eaa35dfa61918b8ae0c36e95d9d10039b7d592fb872f1ac102039741a60715123cf7b1f45a47455c527cb6362cdfc68effc6fbd8d1032e8e9c87d0c3054c0 SHA512 8b597015d2c962713b34366dec82e804c4f50489395165176f9ddb59312cc4466035132418b01befedbc52e21ba19aac88977d372ba2be026fb67d01a9d94927
diff --git a/media-plugins/mythplugins/mythplugins-31.0_p20210731.ebuild b/media-plugins/mythplugins/mythplugins-31.0_p20210731.ebuild
new file mode 100644
index 000000000000..efe6e121074a
--- /dev/null
+++ b/media-plugins/mythplugins/mythplugins-31.0_p20210731.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit python-single-r1 readme.gentoo-r1
+
+# Grab only the major version number.
+MAJOR_PV=$(ver_cut 1)
+
+MY_COMMIT="5824c588db24b4e71a7d94e829e6419f71089297"
+
+DESCRIPTION="Official MythTV plugins"
+HOMEPAGE="https://www.mythtv.org https://github.com/MythTV/mythtv"
+if [[ $(ver_cut 3) == "p" ]] ; then
+ SRC_URI="https://github.com/MythTV/mythtv/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ # mythtv and mythplugins are separate builds in the same github MythTV/mythtv repository
+ S="${WORKDIR}/mythtv-${MY_COMMIT}/mythplugins"
+else
+ SRC_URI="https://github.com/MythTV/mythtv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ # mythtv and mythplugins are separate builds in the same github MythTV/mythtv repository
+ SRC_URI="https://github.com/MythTV/mythtv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/mythtv-${PV}/mythplugins"
+fi
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+MYTHPLUGINS="mytharchive mythbrowser mythgame \
+mythmusic mythnetvision mythnews mythweather mythzmserver mythzoneminder"
+IUSE="${MYTHPLUGINS} alsa cdda cdr exif fftw +hls ieee1394 libass +opengl raw +theora +vorbis +xml xvid"
+
+# Mythnetvision temporarily disabled by upstream - should be fixed soon.
+REQUIRED_USE="
+ !mythnetvision
+ mytharchive? ( ${PYTHON_REQUIRED_USE} )
+ mythnetvision? ( ${PYTHON_REQUIRED_USE} )
+ mythmusic? ( vorbis )
+ mythnews? ( mythbrowser )
+"
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/openssl:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtsql:5
+ media-libs/freetype:2
+ media-libs/libpng:=
+ virtual/libudev:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXv
+ x11-libs/libXxf86vm
+ alsa? ( media-libs/alsa-lib )
+ hls? (
+ media-libs/faac
+ media-libs/libvpx:=
+ media-libs/x264:=
+ media-sound/lame
+ )
+ ieee1394? (
+ media-libs/libiec61883
+ sys-libs/libavc1394
+ sys-libs/libraw1394
+ )
+ libass? ( media-libs/libass:= )
+ =media-tv/mythtv-${MAJOR_PV}*[alsa?,cdda?,cdr?,exif?,fftw?,ieee1394?,libass?,opengl?,raw?,xml?,xvid]
+ mytharchive? (
+ ${PYTHON_DEPS}
+ app-cdr/dvd+rw-tools
+ dev-python/pillow
+ dev-python/mysqlclient
+ =media-tv/mythtv-${MAJOR_PV}*[python]
+ media-video/dvdauthor
+ media-video/mjpegtools[png]
+ media-video/transcode
+ app-cdr/cdrtools
+ )
+ mythbrowser? ( dev-qt/qtwebkit:5 )
+ mythgame? (
+ sys-libs/zlib[minizip]
+ dev-perl/XML-Twig
+ )
+ mythmusic? (
+ dev-qt/qtwebkit:5
+ media-libs/flac
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/taglib
+ media-sound/lame
+ fftw? ( sci-libs/fftw:3.0= )
+ opengl? ( virtual/opengl )
+ cdda? (
+ media-sound/cdparanoia
+ dev-libs/libcdio:=
+ cdr? ( app-cdr/cdrtools )
+ )
+ )
+ mythnetvision? (
+ ${PYTHON_DEPS}
+ dev-python/lxml
+ dev-python/oauth2
+ dev-python/pycurl
+ dev-python/urllib3
+ =media-tv/mythtv-${MAJOR_PV}*[python]
+ )
+ mythweather? (
+ dev-perl/Date-Manip
+ dev-perl/XML-Simple
+ dev-perl/XML-XPath
+ dev-perl/DateTime
+ dev-perl/Image-Size
+ dev-perl/DateTime-Format-ISO8601
+ dev-perl/SOAP-Lite
+ dev-perl/JSON
+ =media-tv/mythtv-${MAJOR_PV}*[perl]
+ )
+ mythzmserver? ( dev-db/mysql-connector-c:= )
+ theora? ( media-libs/libtheora )
+ xml? ( dev-libs/libxml2:= )
+ xvid? ( media-libs/xvid )
+"
+DEPEND=${RDEPEND}
+
+DOC_CONTENTS="
+Mythgallery code moved to mythtv and is no longer a plugin in version 31.0.
+As of 3/23/2020, MythNetVision is disabled, work in progress.
+
+No plugins are installed by default. Enable plugins individually with USE flags:
+mytharchive mythbrowser mythgame mythmusic mythnetvision mythnews mythweather mythzmserver mythzoneminder
+"
+
+src_configure() {
+ econf \
+ --python=${EPYTHON} \
+ --extra-ldflags="${LDFLAGS}" \
+ $(use_enable cdda cdio) \
+ $(use_enable exif) \
+ $(use_enable exif new-exif) \
+ $(use_enable fftw) \
+ $(use_enable opengl) \
+ $(use_enable raw dcraw) \
+ $(use_enable mytharchive) \
+ $(use_enable mythbrowser) \
+ $(use_enable mythgame) \
+ $(use_enable mythmusic) \
+ $(use_enable mythnetvision) \
+ $(use_enable mythnews) \
+ $(use_enable mythweather) \
+ $(use_enable mythzmserver) \
+ $(use_enable mythzoneminder)
+}
+
+src_install() {
+ emake STRIP="true" INSTALL_ROOT="${D}" install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}