summaryrefslogtreecommitdiff
path: root/media-plugins/kodi-pvr-hts/kodi-pvr-hts-8.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/kodi-pvr-hts/kodi-pvr-hts-8.4.0.ebuild')
-rw-r--r--media-plugins/kodi-pvr-hts/kodi-pvr-hts-8.4.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-plugins/kodi-pvr-hts/kodi-pvr-hts-8.4.0.ebuild b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-8.4.0.ebuild
new file mode 100644
index 000000000000..2229139c850a
--- /dev/null
+++ b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-8.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Tvheadend Live TV and Radio PVR client addon for Kodi"
+HOMEPAGE="https://github.com/kodi-pvr/pvr.hts"
+SRC_URI=""
+
+if [[ ${PV} == 9999 ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-pvr/pvr.hts.git"
+ inherit git-r3
+else
+ CODENAME="Matrix"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kodi-pvr/pvr.hts/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.hts-${PV}-${CODENAME}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-19*
+ "
+
+RDEPEND="
+ ${DEPEND}
+ "