summaryrefslogtreecommitdiff
path: root/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.22.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.22.11.ebuild')
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.22.11.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.22.11.ebuild b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.22.11.ebuild
new file mode 100644
index 000000000000..f62ec7647a20
--- /dev/null
+++ b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.22.11.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer-meson
+
+DESCRIPTION="Smooth Streaming plugin for GStreamer"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=">=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ gstreamer_system_package gstcodecparsers_dep:gstreamer-codecparsers
+ gstreamer_system_library \
+ gstadaptivedemux_dep:gstadaptivedemux \
+ gstisoff_dep:gstisoff \
+ gsturidownloader_dep:gsturidownloader
+}
+
+pkg_postinst() {
+ einfo "media-plugins/gst-plugins-adaptivedemux2 provides an alternative smooth streaming demuxer option (mssdemux2)"
+}