summaryrefslogtreecommitdiff
path: root/media-libs
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/Manifest.gzbin67070 -> 67063 bytes
-rw-r--r--media-libs/libsidplayfp/Manifest2
-rw-r--r--media-libs/libsidplayfp/libsidplayfp-2.4.0.ebuild29
-rw-r--r--media-libs/libsoundtouch/Manifest2
-rw-r--r--media-libs/libsoundtouch/libsoundtouch-2.3.2.ebuild60
5 files changed, 93 insertions, 0 deletions
diff --git a/media-libs/Manifest.gz b/media-libs/Manifest.gz
index f91f88ae354f..934e0064479c 100644
--- a/media-libs/Manifest.gz
+++ b/media-libs/Manifest.gz
Binary files differ
diff --git a/media-libs/libsidplayfp/Manifest b/media-libs/libsidplayfp/Manifest
index 1577f7574807..f03c0617ccbf 100644
--- a/media-libs/libsidplayfp/Manifest
+++ b/media-libs/libsidplayfp/Manifest
@@ -1,3 +1,5 @@
DIST libsidplayfp-2.3.1.tar.gz 797779 BLAKE2B 45bf858fc984b10538e322c3d1473c490ff1ef88d0e9db170121fefe68356435ddf649bb897c265253632b4b5949e6b417b9c74141d92dca9d6099d7a429784c SHA512 28c33a33ce40df432731afc66e315fe6909edb964fc39f50011761bda43b892e46a758453d191c26da63123fb4fab755f66333ad9c70c1e679c5cad8438a8e22
+DIST libsidplayfp-2.4.0.tar.gz 794252 BLAKE2B 5074e5f286b15dd419aceb3eb5b35903de45b75c0e6ec98b5419a285d28547e46d0f635f8c9882dc0630d3f91741573829c87bb786a79f0b779244d37c4e6e9d SHA512 bbe06069d578227e04c4c950dc66c6b35f856f0df4511b4d9669bbf92892327b6c488786678570357a7622150fc0984bfab0570f581a5a9caa2e04a4dcc8368e
EBUILD libsidplayfp-2.3.1.ebuild 672 BLAKE2B 2ea17f4a44c75233f5bd8ba7cd273a9c7881385643623c49e5c4513aed5bad0022680ba2f13ad557c5c4c2dbd0529d8ee5d7ba920bfcf411a5ab4e5c6b299117 SHA512 b6555f22398a1c7a1663928a8e579c0380eaf955fae30cc6960b624a3c53354bfaeca39e753cec5331fb0ede00459c45537dea30f154d6e7fd00ec3b9cafc80d
+EBUILD libsidplayfp-2.4.0.ebuild 674 BLAKE2B 162f397cd303034d5563f4adf503b94490e6f40c9853e62a1a6f67212645f689d5c7c83a6a86921f2122df6fbbf0966abaa880270ffdee40920b6fa25d34f7a6 SHA512 aa1cf65023f53c62597f09c90c9c057e41c688b45aca4e4f35b0132e50ab1a08ed54e02ab3b1ba7fd4c48da48f13f2ae0d29b36c339dba39a00b2b4b43c34a00
MISC metadata.xml 339 BLAKE2B 79d766f101909c202affb7cc72bbefdfb8d5b44fcbf74f17f98e665351384a8110aec7ddec0c685fb328198d29ae4953ce341cda3dd4abd2a67f157d90628175 SHA512 172879da9ed0be1ff48d75d23d3b23e3070247b4ef1decb291b020f7bc1522dd033e78f92d38511eedaae7c1944edc5bb05ff763f4d20a6b7015198ebd38f16f
diff --git a/media-libs/libsidplayfp/libsidplayfp-2.4.0.ebuild b/media-libs/libsidplayfp/libsidplayfp-2.4.0.ebuild
new file mode 100644
index 000000000000..cc286dae945a
--- /dev/null
+++ b/media-libs/libsidplayfp/libsidplayfp-2.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library for the sidplay2 fork with resid-fp"
+HOMEPAGE="https://sourceforge.net/projects/sidplay-residfp/"
+SRC_URI="mirror://sourceforge/sidplay-residfp/${PN}/$(ver_cut 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/6"
+KEYWORDS="~amd64 ~hppa ~riscv ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ # fix automagic. warning: modifying .ac triggers maintainer mode.
+ sed -i -e 's:doxygen:dIsAbLe&:' configure || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/media-libs/libsoundtouch/Manifest b/media-libs/libsoundtouch/Manifest
index 9f8ec085421d..75558cba6e41 100644
--- a/media-libs/libsoundtouch/Manifest
+++ b/media-libs/libsoundtouch/Manifest
@@ -1,3 +1,5 @@
DIST soundtouch-2.3.1.tar.bz2 529126 BLAKE2B f8ba587ac199cd1e91f3d3487b81457b7c7bb2b4dca8867376ae47f92bf4d5e60aef3d310eab56510995d5ce72e94ce55ecc4e601bfb3b4eba52c40982032d6b SHA512 9fac7484aead1a20aae019b29847ea13ad6d8cb72272313fcffd859b31479d2ab2fe2f69cfef2b3fd35e9b03923d095bf44a67b46f2b313ac711aa31df0fdd59
+DIST soundtouch-2.3.2.tar.gz 583373 BLAKE2B cd3c8fffaa81a2ed867f5a564dd7ff3047b4de576536c3c116162981261bf3789d16def1c94e5be2450373be3f61fd67fa44e3552e19cad7b7d5d56500b98255 SHA512 72cd38f3e11f3c55ff7ed3691fd9a749a5f8d072e08ed03f2fd43a8664962138afaf3e4647116940e86f6ae374a1ba3bcd4b108280da29f3ffa6091cf383ea35
EBUILD libsoundtouch-2.3.1.ebuild 1580 BLAKE2B 96f5f32e57f59fab94d6f23183c6349c47c2153dc8cdff58e52170422227b60057e1537240daff4820bf55da3e11a89078a9f870ebfa42e76d3f247e18d3ee63 SHA512 f89fdadddf1a75cc14d5cd3faf0a5ca0b94f62756cf825b24e82eaa9f897913e6ee5f4cb4fdb54e51a120082914154044a86a7dda6c86439d6ac80a0c34b9f68
+EBUILD libsoundtouch-2.3.2.ebuild 1563 BLAKE2B 56c9b033767c7464b1a3cfa00615ec34ed42c0301a509ad98836b82d7eefe4e98936c11df870fb04382b5670d41faf5220cf6f044cf3934566c4b123965d6d1f SHA512 5753ad168d9cd49674e9a45eb144eb89a4c2e68688afe80968cd65354bd4f0ca13c64a63d8b549d7edb5be472f65c1bfb69962870eb085eb45305ddbc9d50c1b
MISC metadata.xml 254 BLAKE2B 7f76152858fde96b9de5250e4cba30bfe0c5f2aa6ec7c84316072d84e4b664ecd6485642d3d184b1f2ddde8d9e03a94dd47dd00c5b8d82f80c5c0993d5627593 SHA512 7ed31d18221f55928f798dbf095166f535f7c0f5a1c3010b5113fd6b0d275af283f3d2e6839591335ec93bcd50aab5d0f104ad76eefda4d7a6b64d41af183f0b
diff --git a/media-libs/libsoundtouch/libsoundtouch-2.3.2.ebuild b/media-libs/libsoundtouch/libsoundtouch-2.3.2.ebuild
new file mode 100644
index 000000000000..0b26840141e7
--- /dev/null
+++ b/media-libs/libsoundtouch/libsoundtouch-2.3.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools multilib-minimal toolchain-funcs
+
+MY_PN=${PN/lib}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Audio processing library for changing tempo, pitch and playback rates"
+HOMEPAGE="https://www.surina.net/soundtouch/ https://gitlab.com/soundtouch/soundtouch"
+SRC_URI="https://www.surina.net/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+# subslot = libSoundTouch.so soname
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="cpu_flags_x86_sse openmp static-libs"
+
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_PN}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ sed -i "s:^\(dist_doc_DATA=\)COPYING.TXT :\1:" Makefile.am || die
+ sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' configure.ac || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ --disable-integer-samples
+ $(use_enable cpu_flags_x86_sse x86-optimizations)
+ $(use_enable openmp)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" pkgdocdir="${EPREFIX}"/usr/share/doc/${PF}/html install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+}