summaryrefslogtreecommitdiff
path: root/media-libs/zimg/zimg-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/zimg/zimg-9999.ebuild')
-rw-r--r--media-libs/zimg/zimg-9999.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/media-libs/zimg/zimg-9999.ebuild b/media-libs/zimg/zimg-9999.ebuild
index 2c7c54c43cfe..1db3c69e1757 100644
--- a/media-libs/zimg/zimg-9999.ebuild
+++ b/media-libs/zimg/zimg-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} = *9999* ]] ; then
EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
@@ -30,3 +30,10 @@ multilib_src_configure() {
$(use_enable debug) \
$(use_enable static-libs static)
}
+
+multilib_src_install_all() {
+ einstalldocs
+ if ! use static-libs; then
+ find "${ED}" -type f -name '*.la' -delete || die
+ fi
+}