summaryrefslogtreecommitdiff
path: root/media-libs/zimg/zimg-3.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/zimg/zimg-3.0.2.ebuild')
-rw-r--r--media-libs/zimg/zimg-3.0.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-libs/zimg/zimg-3.0.2.ebuild b/media-libs/zimg/zimg-3.0.2.ebuild
new file mode 100644
index 000000000000..c7a443af6834
--- /dev/null
+++ b/media-libs/zimg/zimg-3.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+inherit autotools multilib-minimal
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="debug static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}