summaryrefslogtreecommitdiff
path: root/media-libs/waffle/waffle-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/waffle/waffle-9999.ebuild')
-rw-r--r--media-libs/waffle/waffle-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/media-libs/waffle/waffle-9999.ebuild b/media-libs/waffle/waffle-9999.ebuild
index 1786f943ad96..43899a8515c6 100644
--- a/media-libs/waffle/waffle-9999.ebuild
+++ b/media-libs/waffle/waffle-9999.ebuild
@@ -7,8 +7,9 @@ if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/${PN}"
GIT_ECLASS="git-r3"
else
- SRC_URI="https://gitlab.freedesktop.org/mesa/${PN}/-/raw/website/files/release/${P}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ SRC_URI="https://gitlab.freedesktop.org/mesa/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ KEYWORDS="amd64 arm ~arm64 ~ppc ~ppc64 x86"
+ S="${WORKDIR}"/${PN}-v${PV}
fi
inherit meson multilib-minimal ${GIT_ECLASS}
@@ -47,7 +48,7 @@ multilib_src_configure() {
$(meson_feature X x11_egl)
$(meson_feature gbm)
$(meson_feature egl surfaceless_egl)
- -Dbuild-manpages=true
+ -Dbuild-manpages=$(multilib_is_native_abi && echo true || echo false)
-Dbuild-tests=false
)
meson_src_configure
@@ -60,5 +61,7 @@ multilib_src_compile() {
multilib_src_install() {
meson_src_install
- ! use doc && rm -rf "${D}"/usr/share/doc/waffle1
+ ! use doc && rm -rf \
+ "${D}"/usr/share/doc/waffle1 \
+ "${D}"/usr/share/man/man{3,7}
}