summaryrefslogtreecommitdiff
path: root/media-libs/waffle/waffle-1.7.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/waffle/waffle-1.7.2.ebuild')
-rw-r--r--media-libs/waffle/waffle-1.7.2.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/media-libs/waffle/waffle-1.7.2.ebuild b/media-libs/waffle/waffle-1.7.2.ebuild
deleted file mode 100644
index 05018931d784..000000000000
--- a/media-libs/waffle/waffle-1.7.2.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/${PN}"
- GIT_ECLASS="git-r3"
-else
- SRC_URI="https://gitlab.freedesktop.org/mesa/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
- KEYWORDS="amd64 arm ~arm64 ~ppc ~ppc64 x86"
- S="${WORKDIR}"/${PN}-v${PV}
-fi
-inherit meson-multilib multilib ${GIT_ECLASS}
-
-DESCRIPTION="Library that allows selection of GL API and of window system at runtime"
-HOMEPAGE="https://gitlab.freedesktop.org/mesa/waffle"
-
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="doc +egl +gbm wayland X"
-RESTRICT="test" # gl_basic tests don't work when run from portage
-
-RDEPEND="
- >=media-libs/mesa-9.1.6[egl(+)?,gbm(+)?,${MULTILIB_USEDEP}]
- X? (
- >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
- >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
- )
- gbm? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] )
- wayland? ( >=dev-libs/wayland-1.10[${MULTILIB_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- X? ( >=x11-base/xcb-proto-1.8-r3 )
-"
-BDEPEND="
- app-text/docbook-xml-dtd:4.2
- dev-libs/libxslt
- dev-util/wayland-scanner
-"
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/wflinfo$(get_exeext)
-)
-
-multilib_src_configure() {
- local emesonargs=(
- $(meson_feature X glx)
- $(meson_feature wayland)
- $(meson_feature X x11_egl)
- $(meson_feature gbm)
- $(meson_feature egl surfaceless_egl)
- $(meson_native_true build-manpages)
- -Dbuild-tests=false
- )
- meson_src_configure
-}
-
-multilib_src_install() {
- meson_src_install
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- rm -r \
- "${ED}"/usr/share/doc/${P} \
- "${ED}"/usr/share/doc/waffle1/release-notes || die
- mv "${ED}"/usr/share/doc/{waffle1,${P}} || die
- if ! use doc; then
- rm -rf \
- "${ED}"/usr/share/man/man{3,7} || die
- fi
-}