summaryrefslogtreecommitdiff
path: root/media-libs/tg_owt/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/tg_owt/files')
-rw-r--r--media-libs/tg_owt/files/tg_owt-0_pre20211207-fix-dcsctp-references.patch17
-rw-r--r--media-libs/tg_owt/files/tg_owt-0_pre20220209-allow-disabling-X11.patch117
-rw-r--r--media-libs/tg_owt/files/tg_owt-0_pre20220209-gcc-12-cstddef.patch20
3 files changed, 0 insertions, 154 deletions
diff --git a/media-libs/tg_owt/files/tg_owt-0_pre20211207-fix-dcsctp-references.patch b/media-libs/tg_owt/files/tg_owt-0_pre20211207-fix-dcsctp-references.patch
deleted file mode 100644
index 7b3380dd55de..000000000000
--- a/media-libs/tg_owt/files/tg_owt-0_pre20211207-fix-dcsctp-references.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Fix undefined references to dcsctp when linking this library
-
-/usr/lib/gcc/x86_64-pc-linux-gnu/11.2.1/../../../../x86_64-pc-linux-gnu/bin/ld: /usr/lib64/libtg_owt.so.0.0.0: undefined reference to `dcsctp::TaskQueueTimeoutFactory::TaskQueueTimeout::TaskQueueTimeout(dcsctp::TaskQueueTimeoutFactory&)'
-/usr/lib/gcc/x86_64-pc-linux-gnu/11.2.1/../../../../x86_64-pc-linux-gnu/bin/ld: /usr/lib64/libtg_owt.so.0.0.0: undefined reference to `dcsctp::DcSctpSocketFactory::Create(std::basic_string_view<char, std::char_traits<char> >, dcsctp::DcSctpSocketCallbacks&, std::unique_ptr<dcsctp::PacketObserver, std::default_delete<dcsctp::PacketObserver> >, dcsctp::DcSctpOptions const&)'
-/usr/lib/gcc/x86_64-pc-linux-gnu/11.2.1/../../../../x86_64-pc-linux-gnu/bin/ld: /usr/lib64/libtg_owt.so.0.0.0: undefined reference to `vtable for dcsctp::TextPcapPacketObserver'
-
---- tg_owt-d5c3d43b959c7e9e7d8004b9b7fdadd12ce7d589.orig/CMakeLists.txt
-+++ tg_owt-d5c3d43b959c7e9e7d8004b9b7fdadd12ce7d589/CMakeLists.txt
-@@ -808,8 +808,6 @@
- media/engine/webrtc_media_engine_defaults.cc
- media/engine/webrtc_video_engine.cc
- media/engine/webrtc_voice_engine.cc
-- media/sctp/dcsctp_transport.cc
-- media/sctp/dcsctp_transport.h
- media/sctp/sctp_transport_factory.cc
- media/sctp/sctp_transport_factory.h
- media/sctp/usrsctp_transport.cc
diff --git a/media-libs/tg_owt/files/tg_owt-0_pre20220209-allow-disabling-X11.patch b/media-libs/tg_owt/files/tg_owt-0_pre20220209-allow-disabling-X11.patch
deleted file mode 100644
index 3d4acfd0d941..000000000000
--- a/media-libs/tg_owt/files/tg_owt-0_pre20220209-allow-disabling-X11.patch
+++ /dev/null
@@ -1,117 +0,0 @@
-Add -DTG_OWT_USE_X11
-
-Allows disabling X11 desktop capturing independently of pipewire support, for
-the few people that run wayland without any X11 support whatsoever.
-
-This setup is untested, but supported by the GNI build system, see:
-* src/modules/desktop_capture/BUILD.gn (option rtc_use_x11_extensions)
-
-Toggling the WEBRTC_USE_X11 define also affects some files under
-src/modules/audio_device, but that falls under "X11 support", regardless...
-
---- tg_owt-4cba1acdd718b700bb33945c0258283689d4eac7.orig/CMakeLists.txt
-+++ tg_owt-4cba1acdd718b700bb33945c0258283689d4eac7/CMakeLists.txt
-@@ -21,11 +21,13 @@
-
- option(BUILD_SHARED_LIBS "Builds shared libraries instead of static." OFF)
- option(TG_OWT_USE_PROTOBUF "Use protobuf to generate additional headers. Useful for packaged build." ${BUILD_SHARED_LIBS})
-+option(TG_OWT_USE_X11 "Use X11 for desktop capture on non-Apple Unix." ON)
- option(TG_OWT_USE_PIPEWIRE "Use pipewire for desktop capture on non-Apple Unix." ON)
- option(TG_OWT_DLOPEN_PIPEWIRE "dlopen pipewire 0.3 for desktop capture on non-Apple Unix." ${not_packaged_build})
- option(TG_OWT_BUILD_AUDIO_BACKENDS "Build webrtc audio backends." OFF)
-
- if (NOT UNIX OR APPLE)
-+ set(TG_OWT_USE_X11 OFF)
- set(TG_OWT_USE_PIPEWIRE OFF)
- endif()
-
-@@ -97,6 +99,10 @@
- add_library(tg_owt)
- init_target(tg_owt)
-
-+if (TG_OWT_USE_X11)
-+ link_x11(tg_owt)
-+endif()
-+
- if (TG_OWT_USE_PIPEWIRE)
- if (TG_OWT_DLOPEN_PIPEWIRE)
- include(cmake/generate_stubs.cmake)
-@@ -188,10 +194,6 @@
- include(cmake/libwebrtcbuild.cmake)
- target_link_libraries(tg_owt PUBLIC tg_owt::libwebrtcbuild)
-
--if (UNIX AND NOT APPLE)
-- link_x11(tg_owt)
--endif()
--
- function(add_sublibrary postfix)
- add_library(tg_owt_${postfix} OBJECT)
- init_feature_target(tg_owt_${postfix} ${postfix})
-@@ -2258,6 +2260,39 @@
- )
- endif()
-
-+if (NOT TG_OWT_USE_X11)
-+ remove_target_sources(tg_owt ${webrtc_loc}
-+ # src/modules/desktop_capture/BUILD.gn (rtc_use_x11_extensions)
-+ modules/desktop_capture/linux/mouse_cursor_monitor_x11.cc
-+ modules/desktop_capture/linux/mouse_cursor_monitor_x11.h
-+ modules/desktop_capture/linux/screen_capturer_x11.cc
-+ modules/desktop_capture/linux/screen_capturer_x11.h
-+ modules/desktop_capture/linux/shared_x_display.cc
-+ modules/desktop_capture/linux/shared_x_display.h
-+ modules/desktop_capture/linux/window_capturer_x11.cc
-+ modules/desktop_capture/linux/window_capturer_x11.h
-+ modules/desktop_capture/linux/window_finder_x11.cc
-+ modules/desktop_capture/linux/window_finder_x11.h
-+ modules/desktop_capture/linux/window_list_utils.cc
-+ modules/desktop_capture/linux/window_list_utils.h
-+ modules/desktop_capture/linux/x_atom_cache.cc
-+ modules/desktop_capture/linux/x_atom_cache.h
-+ modules/desktop_capture/linux/x_error_trap.cc
-+ modules/desktop_capture/linux/x_error_trap.h
-+ modules/desktop_capture/linux/x_server_pixel_buffer.cc
-+ modules/desktop_capture/linux/x_server_pixel_buffer.h
-+ modules/desktop_capture/linux/x_window_property.cc
-+ modules/desktop_capture/linux/x_window_property.h
-+
-+ # screen_drawer_linux.cc depends on x11, rest are revdeps
-+ modules/desktop_capture/screen_drawer.cc
-+ modules/desktop_capture/screen_drawer.h
-+ modules/desktop_capture/screen_drawer_linux.cc
-+ modules/desktop_capture/screen_drawer_lock_posix.cc
-+ modules/desktop_capture/screen_drawer_lock_posix.h
-+ )
-+endif()
-+
- if (NOT TG_OWT_USE_PIPEWIRE)
- remove_target_sources(tg_owt ${webrtc_loc}
- modules/desktop_capture/linux/base_capturer_pipewire.cc
---- tg_owt-4cba1acdd718b700bb33945c0258283689d4eac7.orig/cmake/libwebrtcbuild.cmake
-+++ tg_owt-4cba1acdd718b700bb33945c0258283689d4eac7/cmake/libwebrtcbuild.cmake
-@@ -28,6 +28,13 @@
- BWE_TEST_LOGGING_COMPILE_TIME_ENABLE=0
- )
-
-+if (TG_OWT_USE_X11)
-+ target_compile_definitions(libwebrtcbuild
-+ INTERFACE
-+ WEBRTC_USE_X11
-+ )
-+endif()
-+
- if (TG_OWT_USE_PIPEWIRE)
- target_compile_definitions(libwebrtcbuild
- INTERFACE
-@@ -64,11 +71,6 @@
- INTERFACE
- WEBRTC_MAC
- )
-- else()
-- target_compile_definitions(libwebrtcbuild
-- INTERFACE
-- WEBRTC_USE_X11
-- )
- endif()
-
- if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
diff --git a/media-libs/tg_owt/files/tg_owt-0_pre20220209-gcc-12-cstddef.patch b/media-libs/tg_owt/files/tg_owt-0_pre20220209-gcc-12-cstddef.patch
deleted file mode 100644
index c79d6068945e..000000000000
--- a/media-libs/tg_owt/files/tg_owt-0_pre20220209-gcc-12-cstddef.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-https://bugs.gentoo.org/840526
---- a/src/modules/rtp_rtcp/source/rtp_packetizer_av1_test_helper.cc
-+++ b/src/modules/rtp_rtcp/source/rtp_packetizer_av1_test_helper.cc
-@@ -10,6 +10,7 @@
-
- #include "modules/rtp_rtcp/source/rtp_packetizer_av1_test_helper.h"
-
-+#include <cstddef>
- #include <stdint.h>
-
- #include <initializer_list>
-@@ -42,7 +43,7 @@ std::vector<uint8_t> BuildAv1Frame(std::initializer_list<Av1Obu> obus) {
- }
- if (obu.header_ & kAv1ObuSizePresentBit) {
- // write size in leb128 format.
-- size_t payload_size = obu.payload_.size();
-+ std::size_t payload_size = obu.payload_.size();
- while (payload_size >= 0x80) {
- raw.push_back(0x80 | (payload_size & 0x7F));
- payload_size >>= 7;