summaryrefslogtreecommitdiff
path: root/media-libs/stimg/stimg-0.1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/stimg/stimg-0.1.0-r1.ebuild')
-rw-r--r--media-libs/stimg/stimg-0.1.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-libs/stimg/stimg-0.1.0-r1.ebuild b/media-libs/stimg/stimg-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..dd1d5aac1d48
--- /dev/null
+++ b/media-libs/stimg/stimg-0.1.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Simple and tiny image loading library"
+HOMEPAGE="http://homepage3.nifty.com/slokar/fb/"
+SRC_URI="http://homepage3.nifty.com/slokar/stimg/${P}.tar.gz"
+
+LICENSE="LGPL-2+ MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc x86"
+
+RDEPEND="
+ media-libs/libpng:=
+ media-libs/libjpeg-turbo:=
+ media-libs/tiff:=
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libpng15.patch
+)
+
+src_prepare() {
+ default
+
+ # bug #871486
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ default
+}
+
+src_install() {
+ default
+
+ # No static archives
+ find "${ED}" -name '*.la' -delete || die
+}