summaryrefslogtreecommitdiff
path: root/media-libs/opencv/opencv-4.5.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/opencv/opencv-4.5.2-r1.ebuild')
-rw-r--r--media-libs/opencv/opencv-4.5.2-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/media-libs/opencv/opencv-4.5.2-r1.ebuild b/media-libs/opencv/opencv-4.5.2-r1.ebuild
index d978b3421497..05330abd0960 100644
--- a/media-libs/opencv/opencv-4.5.2-r1.ebuild
+++ b/media-libs/opencv/opencv-4.5.2-r1.ebuild
@@ -21,7 +21,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
LICENSE="Apache-2.0"
SLOT="0/${PV}" # subslot = libopencv* soname version
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
IUSE="contrib contribcvv contribdnn contribfreetype contribhdf contribovis contribsfm contribxfeatures2d cuda debug dnnsamples download +eigen examples +features2d ffmpeg gdal gflags glog gphoto2 gstreamer gtk3 ieee1394 jpeg jpeg2k lapack lto opencl openexr opengl openmp opencvapps png +python qt5 tesseract testprograms threads tiff vaapi v4l vtk webp xine"
# The following lines are shamelessly stolen from ffmpeg-9999.ebuild with modifications
@@ -58,10 +58,12 @@ IUSE="${IUSE} ${CPU_FEATURES_MAP[@]%:*}"
# OpenGL needs gtk or Qt installed to activate, otherwise build system
# will silently disable it Wwithout the user knowing, which defeats the
# purpose of the opengl use flag.
+# cuda needs contrib, bug #701712
REQUIRED_USE="
cpu_flags_x86_avx2? ( cpu_flags_x86_f16c )
cpu_flags_x86_f16c? ( cpu_flags_x86_avx )
- cuda? ( tesseract? ( opencl ) )
+ cuda? ( contrib
+ tesseract? ( opencl ) )
dnnsamples? ( examples )
gflags? ( contrib )
glog? ( contrib )