summaryrefslogtreecommitdiff
path: root/media-libs/openctm/openctm-1.0.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/openctm/openctm-1.0.3-r1.ebuild')
-rw-r--r--media-libs/openctm/openctm-1.0.3-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/media-libs/openctm/openctm-1.0.3-r1.ebuild b/media-libs/openctm/openctm-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..60585930f8ea
--- /dev/null
+++ b/media-libs/openctm/openctm-1.0.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils multilib flag-o-matic toolchain-funcs
+
+MY_P=OpenCTM-${PV}
+
+DESCRIPTION="OpenCTM - the Open Compressed Triangle Mesh."
+HOMEPAGE="http://openctm.sourceforge.net"
+SRC_URI="https://downloads.sourceforge.net/project/openctm/${MY_P}/${MY_P}-src.tar.bz2 -> ${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+DEPEND="
+ dev-libs/tinyxml
+ media-libs/glew:0=
+ media-libs/pnglite
+ sys-libs/zlib
+ virtual/jpeg:0
+ media-libs/freeglut
+ virtual/opengl
+ x11-libs/gtk+:2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-escape-hyphens-in-ctmconv-man-page.patch"
+ "${FILESDIR}/${P}-link-ctmviewer-with-libGLU.patch"
+ "${FILESDIR}/${P}-use-system-libs.patch"
+ "${FILESDIR}/${P}-do-not-set-rpath.patch"
+ "${FILESDIR}/${P}-link-ctmviewer-only-with-necessary-gtk-libs.patch"
+ "${FILESDIR}/${P}-link-ctmviewer-with-libGL.patch"
+ "${FILESDIR}/${P}-create-lib-with-correct-soname-and-symlinks.patch"
+ "${FILESDIR}/${P}-fix-install-paths.patch"
+ "${FILESDIR}/${P}-respect-flags.patch"
+ "${FILESDIR}/${P}-no-strip.patch"
+)
+
+src_prepare() {
+ edos2unix lib/Makefile.linux
+
+ default
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CXX="$(tc-getCXX)" -f Makefile.linux
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="${ED}/usr/$(get_libdir)" -f Makefile.linux install
+}