summaryrefslogtreecommitdiff
path: root/media-libs/oidn/oidn-1.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/oidn/oidn-1.4.1.ebuild')
-rw-r--r--media-libs/oidn/oidn-1.4.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/oidn/oidn-1.4.1.ebuild b/media-libs/oidn/oidn-1.4.1.ebuild
new file mode 100644
index 000000000000..c93dbc1e24ad
--- /dev/null
+++ b/media-libs/oidn/oidn-1.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="Intel(R) Open Image Denoise library"
+HOMEPAGE="http://www.openimagedenoise.org/"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/OpenImageDenoise/oidn.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://github.com/OpenImageDenoise/${PN}/releases/download/v${PV}/${P}.src.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-cpp/tbb
+ dev-lang/ispc"
+BDEPEND="
+ ${RDEPEND}
+ dev-util/cmake"
+
+CMAKE_BUILD_TYPE=Release
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}