summaryrefslogtreecommitdiff
path: root/media-libs/oidn/oidn-1.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/oidn/oidn-1.3.0.ebuild')
-rw-r--r--media-libs/oidn/oidn-1.3.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/media-libs/oidn/oidn-1.3.0.ebuild b/media-libs/oidn/oidn-1.3.0.ebuild
index 7e79c737d50f..9a557e648b0e 100644
--- a/media-libs/oidn/oidn-1.3.0.ebuild
+++ b/media-libs/oidn/oidn-1.3.0.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
-inherit cmake python-single-r1 eutils
+inherit cmake python-single-r1
DESCRIPTION="Intel(R) Open Image Denoise library"
HOMEPAGE="http://www.openimagedenoise.org/"
@@ -16,24 +16,26 @@ if [[ ${PV} = *9999 ]]; then
EGIT_BRANCH="master"
else
SRC_URI="https://github.com/OpenImageDenoise/${PN}/releases/download/v${PV}/${P}.src.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-glibc.patch.bz2"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="Apache-2.0"
SLOT="0"
-IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${PYTHON_DEPS}
dev-cpp/tbb
dev-lang/ispc"
-DEPEND="
+BDEPEND="
${RDEPEND}
dev-util/cmake"
CMAKE_BUILD_TYPE=Release
+PATCHES=( "${WORKDIR}"/oidn-1.3.0-glibc.patch )
+
pkg_setup() {
python-single-r1_pkg_setup
}