summaryrefslogtreecommitdiff
path: root/media-libs/oidn/oidn-1.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/oidn/oidn-1.3.0.ebuild')
-rw-r--r--media-libs/oidn/oidn-1.3.0.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/media-libs/oidn/oidn-1.3.0.ebuild b/media-libs/oidn/oidn-1.3.0.ebuild
deleted file mode 100644
index 9a557e648b0e..000000000000
--- a/media-libs/oidn/oidn-1.3.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8,9} )
-
-inherit cmake python-single-r1
-
-DESCRIPTION="Intel(R) Open Image Denoise library"
-HOMEPAGE="http://www.openimagedenoise.org/"
-
-if [[ ${PV} = *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/OpenImageDenoise/oidn.git"
- EGIT_BRANCH="master"
-else
- SRC_URI="https://github.com/OpenImageDenoise/${PN}/releases/download/v${PV}/${P}.src.tar.gz -> ${P}.tar.gz"
- SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-glibc.patch.bz2"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-cpp/tbb
- dev-lang/ispc"
-BDEPEND="
- ${RDEPEND}
- dev-util/cmake"
-
-CMAKE_BUILD_TYPE=Release
-
-PATCHES=( "${WORKDIR}"/oidn-1.3.0-glibc.patch )
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}