summaryrefslogtreecommitdiff
path: root/media-libs/mesa/mesa-20.3.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/mesa/mesa-20.3.4.ebuild')
-rw-r--r--media-libs/mesa/mesa-20.3.4.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/media-libs/mesa/mesa-20.3.4.ebuild b/media-libs/mesa/mesa-20.3.4.ebuild
index 551fcd5d326d..3bcef8c19175 100644
--- a/media-libs/mesa/mesa-20.3.4.ebuild
+++ b/media-libs/mesa/mesa-20.3.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
else
SRC_URI="https://archive.mesa3d.org/${MY_P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="MIT"
@@ -333,7 +333,15 @@ pkg_setup() {
if use video_cards_i965 ||
use video_cards_iris ||
use video_cards_radeonsi; then
- CONFIG_CHECK="~CHECKPOINT_RESTORE"
+ if kernel_is -ge 5 11 3; then
+ CONFIG_CHECK="~KCMP"
+ elif kernel_is -ge 5 11; then
+ CONFIG_CHECK="~CHECKPOINT_RESTORE"
+ elif kernel_is -ge 5 10 20; then
+ CONFIG_CHECK="~KCMP"
+ else
+ CONFIG_CHECK="~CHECKPOINT_RESTORE"
+ fi
linux-info_pkg_setup
fi