summaryrefslogtreecommitdiff
path: root/media-libs/mesa/files/mesa-18.2.4-meson-link-gallium-nine-with-pthreads.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/mesa/files/mesa-18.2.4-meson-link-gallium-nine-with-pthreads.patch')
-rw-r--r--media-libs/mesa/files/mesa-18.2.4-meson-link-gallium-nine-with-pthreads.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/mesa/files/mesa-18.2.4-meson-link-gallium-nine-with-pthreads.patch b/media-libs/mesa/files/mesa-18.2.4-meson-link-gallium-nine-with-pthreads.patch
new file mode 100644
index 000000000000..11d4f9cac07d
--- /dev/null
+++ b/media-libs/mesa/files/mesa-18.2.4-meson-link-gallium-nine-with-pthreads.patch
@@ -0,0 +1,34 @@
+From 7652931d33b36c93b2e84713baa8c283d568402e Mon Sep 17 00:00:00 2001
+From: Dylan Baker <dylan@pnwbakers.com>
+Date: Thu, 1 Nov 2018 14:12:57 -0700
+Subject: [PATCH] meson: link gallium nine with pthreads
+
+In some cases (not building with llvm, which automatically pulls in
+pthreads) nine needs to be directly linked with pthreads. Fixes building
+on x86 (32 bit) without llvm.
+
+Distro bug: https://bugs.gentoo.org/670094
+Fixes: 6b4c7047d57178d3362a710ad503057c6a582ca3
+ ("meson: build gallium nine state_tracker")
+Tested-by: Rafal Lalik <rafallalik@gmail.com>
+Reviewed-by: Matt Turner <mattst88@gmail.com>
+---
+ src/gallium/targets/d3dadapter9/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/gallium/targets/d3dadapter9/meson.build b/src/gallium/targets/d3dadapter9/meson.build
+index bd05b4f9692..bc72b1110a0 100644
+--- a/src/gallium/targets/d3dadapter9/meson.build
++++ b/src/gallium/targets/d3dadapter9/meson.build
+@@ -53,7 +53,7 @@ libgallium_nine = shared_library(
+ libswkmsdri,
+ ],
+ dependencies : [
+- dep_selinux, dep_expat, dep_libdrm, dep_llvm,
++ dep_selinux, dep_expat, dep_libdrm, dep_llvm, dep_thread,
+ driver_swrast, driver_r300, driver_r600, driver_radeonsi, driver_nouveau,
+ driver_i915, driver_svga,
+ ],
+--
+2.16.4
+