summaryrefslogtreecommitdiff
path: root/media-libs/lilv
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/lilv')
-rw-r--r--media-libs/lilv/Manifest4
-rw-r--r--media-libs/lilv/lilv-0.24.18-r1.ebuild4
-rw-r--r--media-libs/lilv/lilv-0.24.20.ebuild74
3 files changed, 79 insertions, 3 deletions
diff --git a/media-libs/lilv/Manifest b/media-libs/lilv/Manifest
index 04ab06491d9a..5d76d1001903 100644
--- a/media-libs/lilv/Manifest
+++ b/media-libs/lilv/Manifest
@@ -1,3 +1,5 @@
DIST lilv-0.24.18.tar.xz 118216 BLAKE2B c1d191a8513776b4e783f05076b8a8d5a20866e734527ff84e04d970d190b26d2c922aa6f7ba346632caea47daa265c1008d9295c3f0e41f85227103337ccd1f SHA512 eece846338403ba3e7c366024511d33bd5e399d3b1e6871d04ec3907540a9e3541ab7b0445bf17cf61c5779c5263f1ef23eadefb6411a2e4be8d79464a5b873e
-EBUILD lilv-0.24.18-r1.ebuild 1547 BLAKE2B 1d2f3aa6aa9b22e7aa0e7e58f204f49c29b1ebfb2b6727101e3268fa0debf9dd34f708c5ca8fdc1b2ebf15e5622dc0854e89e20ac6530adb7ed09ac2cd102b06 SHA512 39888db622bcb885be0e6d9e961e423837287001268d1b22162b6a63779547305dc3ae7aa10e21595ac29b50ae3b17fed9bff7f5203e5b8e9e04567aa5c32206
+DIST lilv-0.24.20.tar.xz 118460 BLAKE2B 50b2044a7fb62cfcbea6dc68cd0d26503780f30a5a04e2ceafca9e02b2369965d7d27b8d08bbfa136930a3b18a3e0eb6cf4c326d3c2d46218badb4a8ec6e1e01 SHA512 68963b66fd6e577280867fcd5a601fd2cf539a10fcf0b667c22165cc7e42206fd6a20d56dbe97b587fb68f798d4db3b2351b87b1243c665c3a2b1bb82cbbf9a3
+EBUILD lilv-0.24.18-r1.ebuild 1553 BLAKE2B f7318169c5e9f00d605562d290fc06e987447f78cb2cabd1df857dc2b915b4415b2af7f6c9bec73c2dfb92da8fa67edee865fd11b19887a34114d4b0462ed299 SHA512 df06f8ddc6a7b9b3bde3fa3c495dd0ba901225ecca56089de5c1f879b691fadfbe3c3c3b35a40aa7784ec0d9d05bd33d5d792adfc6e935cf68417093b6e5f11d
+EBUILD lilv-0.24.20.ebuild 1559 BLAKE2B e486d3681a52424bec542ebee00929259c17fec303d69d75b4a610f61e6c770ffd292822d695f3d0688c1dbbe70de7258e12f31d643e840a2cddaffd32f67fb2 SHA512 e3f4fef14104cec99c117191c8237ad4fa8eeca91425bbb52242b04cb5634d12268067fe0d54901252cce57f548a124ae773524a8d74312b8f1a258012b78c1e
MISC metadata.xml 573 BLAKE2B 5bc3986be5111f0c3777c47531b3c9677d9aa9ca4e95388472ed8abab5dd8339cf8df16cfba780b06c7cb1241613b02797c7c7b2100e4e2e6f2991ef02b3b9e4 SHA512 9b4fb81ec6e44bfa6a167b74f1ec6577542f88a9925101561cb87da122a4f67081966b71a17f5ce48a8ab251fb86cc82a45f68b4f36d5b66bc2c51623d5661a5
diff --git a/media-libs/lilv/lilv-0.24.18-r1.ebuild b/media-libs/lilv/lilv-0.24.18-r1.ebuild
index a4ebe7246ec7..c413f9e975f5 100644
--- a/media-libs/lilv/lilv-0.24.18-r1.ebuild
+++ b/media-libs/lilv/lilv-0.24.18-r1.ebuild
@@ -9,8 +9,8 @@ PYTHON_REQ_USE='threads(+)'
inherit meson-multilib python-single-r1
DESCRIPTION="Library to make the use of LV2 plugins as simple as possible for applications"
-HOMEPAGE="http://drobilla.net/software/lilv/"
-SRC_URI="http://download.drobilla.net/${P}.tar.xz"
+HOMEPAGE="https://drobilla.net/software/lilv.html"
+SRC_URI="https://download.drobilla.net/${P}.tar.xz"
LICENSE="ISC"
SLOT="0"
diff --git a/media-libs/lilv/lilv-0.24.20.ebuild b/media-libs/lilv/lilv-0.24.20.ebuild
new file mode 100644
index 000000000000..91b3c531e785
--- /dev/null
+++ b/media-libs/lilv/lilv-0.24.20.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit meson-multilib python-single-r1
+
+DESCRIPTION="Library to make the use of LV2 plugins as simple as possible for applications"
+HOMEPAGE="https://drobilla.net/software/lilv.html"
+SRC_URI="https://download.drobilla.net/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc python test tools"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ dev-python/sphinx
+ dev-python/sphinx_lv2_theme
+ )
+"
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/serd[${MULTILIB_USEDEP}]
+ dev-libs/sord[${MULTILIB_USEDEP}]
+ media-libs/libsndfile
+ media-libs/lv2[${MULTILIB_USEDEP}]
+ media-libs/sratom[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_setup
+}
+
+src_prepare() {
+ default
+
+ # fix doc installation path
+ sed -iE "s%install_dir: docdir / 'lilv-0',%install_dir: docdir / '${PF}',%g" doc/c/meson.build || die
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_feature doc docs)
+ $(meson_feature python bindings_py)
+ $(meson_feature test tests)
+ $(meson_feature tools)
+ )
+
+ meson_src_configure
+}
+
+multilib_src_install() {
+ meson_src_install
+ python_optimize
+}
+
+multilib_src_install_all() {
+ local DOCS=( AUTHORS NEWS README.md )
+ einstalldocs
+
+ newenvd - 60lv2 <<-EOF
+ LV2_PATH=${EPREFIX}/usr/$(get_libdir)/lv2
+ EOF
+}