summaryrefslogtreecommitdiff
path: root/media-libs/libvisio/libvisio-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libvisio/libvisio-9999.ebuild')
-rw-r--r--media-libs/libvisio/libvisio-9999.ebuild36
1 files changed, 15 insertions, 21 deletions
diff --git a/media-libs/libvisio/libvisio-9999.ebuild b/media-libs/libvisio/libvisio-9999.ebuild
index e4147a14c125..1f7cc355b43d 100644
--- a/media-libs/libvisio/libvisio-9999.ebuild
+++ b/media-libs/libvisio/libvisio-9999.ebuild
@@ -1,39 +1,35 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=6
inherit flag-o-matic
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libvisio.git"
- inherit autotools git-r3
-else
- SRC_URI="https://dev-www.libreoffice.org/src/libvisio/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-fi
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libvisio.git"
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
-DESCRIPTION="Library parsing the file format of MS Visio documents"
+DESCRIPTION="Library parsing the visio documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
+[[ ${PV} == 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/libvisio/${P}.tar.xz"
LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
IUSE="doc static-libs test tools"
-BDEPEND="
- dev-lang/perl
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
RDEPEND="
dev-libs/icu:=
dev-libs/librevenge
dev-libs/libxml2
"
DEPEND="${RDEPEND}
+ dev-lang/perl
dev-libs/boost
dev-util/gperf
sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
test? ( dev-util/cppunit )
"
@@ -47,13 +43,11 @@ src_configure() {
# bug 619688
append-cxxflags -std=c++14
- local myeconfargs=(
- $(use_with doc docs)
- $(use_enable static-libs static)
- $(use_enable test tests)
+ econf \
+ $(use_with doc docs) \
+ $(use_enable static-libs static) \
+ $(use_enable test tests) \
$(use_enable tools)
- )
- econf "${myeconfargs[@]}"
}
src_install() {