summaryrefslogtreecommitdiff
path: root/media-libs/libtheora/libtheora-1.1.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libtheora/libtheora-1.1.1-r2.ebuild')
-rw-r--r--media-libs/libtheora/libtheora-1.1.1-r2.ebuild35
1 files changed, 15 insertions, 20 deletions
diff --git a/media-libs/libtheora/libtheora-1.1.1-r2.ebuild b/media-libs/libtheora/libtheora-1.1.1-r2.ebuild
index de4b8f692f7f..ff35ecea75a0 100644
--- a/media-libs/libtheora/libtheora-1.1.1-r2.ebuild
+++ b/media-libs/libtheora/libtheora-1.1.1-r2.ebuild
@@ -56,19 +56,13 @@ multilib_src_configure() {
use doc || export ac_cv_prog_HAVE_DOXYGEN=false
local myconf=(
+ # --disable-spec because LaTeX documentation has been prebuilt
--disable-spec
$(use_enable encode)
+ $(multilib_native_use_enable examples)
$(use_enable static-libs static)
)
- if [[ "${ABI}" = "${DEFAULT_ABI}" ]] ; then
- myconf+=( $(use_enable examples) )
- else
- # those will be overwritten anyway
- myconf+=( --disable-examples )
- fi
-
- # --disable-spec because LaTeX documentation has been prebuilt
ECONF_SOURCE="${S}" econf "${myconf[@]}"
}
@@ -77,23 +71,24 @@ multilib_src_install() {
DESTDIR="${D}" \
docdir="${EPREFIX}"/usr/share/doc/${PF} \
install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+
+ einstalldocs
- if use examples && [[ "${ABI}" = "${DEFAULT_ABI}" ]]; then
+ if use examples ; then
dobin examples/.libs/png2theora
for bin in dump_{psnr,video} {encoder,player}_example; do
newbin examples/.libs/${bin} theora_${bin}
done
- fi
-}
-
-multilib_src_install_all() {
- find "${D}" -name '*.la' -delete || die
- einstalldocs
- if use examples && use doc; then
- docinto examples
- dodoc examples/*.[ch]
- docompress -x /usr/share/doc/${PF}/examples
- docinto .
+ if use doc ; then
+ docinto examples
+ dodoc examples/*.[ch]
+ docompress -x /usr/share/doc/${PF}/examples
+ docinto .
+ fi
fi
}