summaryrefslogtreecommitdiff
path: root/media-libs/libshout
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libshout')
-rw-r--r--media-libs/libshout/Manifest1
-rw-r--r--media-libs/libshout/libshout-2.4.1-r1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/media-libs/libshout/Manifest b/media-libs/libshout/Manifest
index 723c4840798a..922389376cf6 100644
--- a/media-libs/libshout/Manifest
+++ b/media-libs/libshout/Manifest
@@ -4,5 +4,6 @@ DIST libshout-2.3.1.tar.gz 464229 BLAKE2B 6266e23d34f551e4d8afacc514a4e2e7bb1275
DIST libshout-2.4.1.tar.gz 516161 BLAKE2B bedea3c043018eff4675fdb8b95e0bb8ff02a98994a4afcc76537124ebf7357f012f2e9445ebd207b576fc4166fb761d65066fe166fc8b611b96f5c5482a0e92 SHA512 4d4b958947e020de3330d49d39d59220fc89315f25f653a7456b9aa24ca9566fca30bb3d65e6348e79958656096b6b864ea8885157d24e55c8d84d6604670219
EBUILD libshout-2.3.1-r1.ebuild 1216 BLAKE2B a56149d45dcf464a465558d926ff2378685ee8ef1f99ea584bd397e455b80aeb9ac0126898ec4474a3e100eb9b4b32a58dc30eb274430121e82935b7a88dd6db SHA512 977452a7ea64d3076f968bffd73cf81f5c87e18bfa760108cf3120a77b60ef4aa528afba4b6e7913d9832c122187afbdc9c8430e8d1104f0656eba20be735d53
EBUILD libshout-2.3.1.ebuild 837 BLAKE2B 06e49c76b036ebe4018cfb40df091f48cda71fe516a32a1517744e89e25c90eb177bfe90cc223255be102cf8cdf2405e8941624f62520b6ca19a4ea8e5ab6169 SHA512 f3ca40a99521c197a07dbcad9458b90243fd1ca36e45cd4c9487feee7115a6598eae6c778307dd22e8133b089c5cfdb47b3d237e9d6bf3f75cefc37d0e657913
+EBUILD libshout-2.4.1-r1.ebuild 1325 BLAKE2B 25e74ac82b2a66078252d9c54822604e247d76824ed964a3aa8eeb59955b08970fb431d2ab13c9bd3a54bd2a501064bc3737fe642d968b1ca698262cb62ffe19 SHA512 7d28ceeb63f48aa87ac69a25802cefa6e17b1a9fc3911687a8756971eead264a4e82b594e45d715417afeef620fb5aa697df7696ceabd62f31adfcb1ebd8254d
EBUILD libshout-2.4.1.ebuild 1340 BLAKE2B 654727adb05205043c5aeeb33b285373a7275a4211f894ec5ae64ac801d98cbfbac84423c7287286e22e12d7e79877a735ee24a21a8485ab274d24210e24e129 SHA512 344835f4c72a272295da03a4a3d9df82049504d8056396b793523965652820b12527d1de9eb2f279a21caf636277d035977c60a4c0b8023c8eafc6d8759ed672
MISC metadata.xml 249 BLAKE2B f7f8f071ecba933f3d39b0b60983281d59299b92de9375a60ab4109d7202800cb790bce0c426227f04b3e2624b1adb20876145741355abc6a4938b8b9698d144 SHA512 9a100fb26586365eda99724330a03a512f4d0be18d39c3a195ba02c2fc841edeee99d22512acf5a058a3b978d3a74f4d963a5aff9aa343b6cb4086cdfefe6343
diff --git a/media-libs/libshout/libshout-2.4.1-r1.ebuild b/media-libs/libshout/libshout-2.4.1-r1.ebuild
new file mode 100644
index 000000000000..21f924bc6668
--- /dev/null
+++ b/media-libs/libshout/libshout-2.4.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="library for connecting and sending data to icecast servers"
+HOMEPAGE="http://www.icecast.org/"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="libressl speex static-libs theora"
+
+RDEPEND="
+ >=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}]
+ >=media-libs/libvorbis-1.3.3-r1[${MULTILIB_USEDEP}]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ speex? ( >=media-libs/speex-1.2_rc1-r1[${MULTILIB_USEDEP}] )
+ theora? ( >=media-libs/libtheora-1.1.1[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/shout/shout.h
+)
+
+DOCS=( README examples/example.c )
+
+PATCHES=( "${FILESDIR}"/${PN}-2.4.1-underlinking.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ $(use_enable theora) \
+ $(use_enable speex)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ rm -rf "${ED}"/usr/share/doc/${PN} || die
+ find "${D}" -name '*.la' -delete || die
+}