summaryrefslogtreecommitdiff
path: root/media-libs/libilbc/libilbc-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libilbc/libilbc-9999.ebuild')
-rw-r--r--media-libs/libilbc/libilbc-9999.ebuild31
1 files changed, 9 insertions, 22 deletions
diff --git a/media-libs/libilbc/libilbc-9999.ebuild b/media-libs/libilbc/libilbc-9999.ebuild
index 1d00bd81c2f7..9f2f31bf171f 100644
--- a/media-libs/libilbc/libilbc-9999.ebuild
+++ b/media-libs/libilbc/libilbc-9999.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit multilib-minimal
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
if [[ ${PV} == *9999 ]]; then
- inherit autotools git-r3
+ inherit git-r3
EGIT_REPO_URI="https://github.com/TimothyGu/${PN}"
else
- SRC_URI="https://github.com/TimothyGu/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+ SRC_URI="https://github.com/TimothyGu/${PN}/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
fi
@@ -17,22 +18,8 @@ DESCRIPTION="Packaged version of iLBC codec from the WebRTC project"
HOMEPAGE="https://github.com/TimothyGu/libilbc"
LICENSE="BSD"
-SLOT="0"
-IUSE="static-libs"
+SLOT="0/3"
-src_prepare() {
- default
- [[ ${PV} == *9999 ]] && eautoreconf
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- $(use_enable static-libs static)
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- # package provides .pc files
- find "${D}" -name '*.la' -delete || die
-}
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.4-respect-CFLAGS.patch"
+)