summaryrefslogtreecommitdiff
path: root/media-libs/libid3tag/libid3tag-0.16.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libid3tag/libid3tag-0.16.1-r1.ebuild')
-rw-r--r--media-libs/libid3tag/libid3tag-0.16.1-r1.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/media-libs/libid3tag/libid3tag-0.16.1-r1.ebuild b/media-libs/libid3tag/libid3tag-0.16.1-r1.ebuild
new file mode 100644
index 000000000000..ad7d73f508f3
--- /dev/null
+++ b/media-libs/libid3tag/libid3tag-0.16.1-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+DESCRIPTION="The MAD id3tag library, Tenacity fork"
+HOMEPAGE="https://github.com/tenacityteam/libid3tag"
+SRC_URI="https://github.com/tenacityteam/libid3tag/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}" # SOVERSION = ${CMAKE_PROJECT_VERSION} in CMakeLists.txt
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="sys-libs/zlib[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"