summaryrefslogtreecommitdiff
path: root/media-libs/libhdhomerun/libhdhomerun-20190621.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libhdhomerun/libhdhomerun-20190621.ebuild')
-rw-r--r--media-libs/libhdhomerun/libhdhomerun-20190621.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/libhdhomerun/libhdhomerun-20190621.ebuild b/media-libs/libhdhomerun/libhdhomerun-20190621.ebuild
new file mode 100644
index 000000000000..6ce4dafdd0c8
--- /dev/null
+++ b/media-libs/libhdhomerun/libhdhomerun-20190621.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="SiliconDust HDHomeRun Utilties"
+HOMEPAGE="https://www.silicondust.com/support/linux/"
+SRC_URI="https://download.silicondust.com/hdhomerun/${PN}_${PV}.tgz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-use_shared_library.patch"
+)
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+ #Remove forced optimization from Makefile
+ sed -i 's:-O2::' Makefile || die "Was the Makefile changed?"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) STRIP=:
+}
+
+src_install() {
+ dobin hdhomerun_config
+ dolib.so libhdhomerun.so
+
+ insinto /usr/include/hdhomerun
+ doins *.h
+}