summaryrefslogtreecommitdiff
path: root/media-libs/libhdhomerun/files/20190621-use_shared_library.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libhdhomerun/files/20190621-use_shared_library.patch')
-rw-r--r--media-libs/libhdhomerun/files/20190621-use_shared_library.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/media-libs/libhdhomerun/files/20190621-use_shared_library.patch b/media-libs/libhdhomerun/files/20190621-use_shared_library.patch
new file mode 100644
index 000000000000..a25b33456cf1
--- /dev/null
+++ b/media-libs/libhdhomerun/files/20190621-use_shared_library.patch
@@ -0,0 +1,16 @@
+--- /Makefile 2019-09-16 10:18:56.033121543 -0500
++++ /Makefile 2019-09-16 10:14:00.110155153 -0500
+@@ -38,10 +38,10 @@
+ endif
+ endif
+
+-all : hdhomerun_config$(BINEXT) libhdhomerun$(LIBEXT)
++all : libhdhomerun$(LIBEXT) hdhomerun_config$(BINEXT)
+
+-hdhomerun_config$(BINEXT) : hdhomerun_config.c $(LIBSRCS)
+- $(CC) $(CFLAGS) $+ $(LDFLAGS) -o $@
++hdhomerun_config$(BINEXT) : hdhomerun_config.c libhdhomerun$(LIBEXT)
++ $(CC) $(CFLAGS) $+ $(LDFLAGS) -L./ -lhdhomerun -o $@
+ $(STRIP) $@
+
+ libhdhomerun$(LIBEXT) : $(LIBSRCS)