summaryrefslogtreecommitdiff
path: root/media-libs/libgpod
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libgpod')
-rw-r--r--media-libs/libgpod/Manifest2
-rw-r--r--media-libs/libgpod/files/libgpod-0.8.3-implicit-int.patch19
-rw-r--r--media-libs/libgpod/libgpod-0.8.3-r6.ebuild78
3 files changed, 99 insertions, 0 deletions
diff --git a/media-libs/libgpod/Manifest b/media-libs/libgpod/Manifest
index bfbb9941c6cd..66dc9cfbb0b0 100644
--- a/media-libs/libgpod/Manifest
+++ b/media-libs/libgpod/Manifest
@@ -1,6 +1,8 @@
AUX libgpod-0.8.3-comment.patch 611 BLAKE2B 6ed4cfbb6ca1ca6876f835bdad2b9d11a8ad147c0f0f584436791fa84e40e15dcbfe163a47dedc688eecf4db84610df81ab01ae2c1266324a8cebadd914627e2 SHA512 a9d042745d8095a8188e57d82c8e1b00acb41f45da1510b2615d29b607b52ae49e54d3482e5021d085501f3705f4ad0fa79796cd4262c74acd0b4f34f8450a44
+AUX libgpod-0.8.3-implicit-int.patch 638 BLAKE2B 55433e6709baf17bc18b9da9b5ca2c15601f3a5b364f52573c21ab49ab18b9089fa5ad318307dc107034faece88416ced565261b23243e42dcfcfdac400efaf3 SHA512 63a1f0c3871f34ae356f3b8f1b465e744d7f6ed656c7ee24a88f2a81742af76c0db44985759d9905dc6fa14b1e98b3654229d3c64c1010b87b16b71ec4059e93
AUX libgpod-0.8.3-pkgconfig_overlinking.patch 640 BLAKE2B 74d924d61ce33c4fd0219e8dedb505bd66cd40e9912efb2dbbb5df31c2bea943ea4a4eb8b9e9baf2762966b02efae3f77c73293f8a4a581f6a43be4cc22eb727 SHA512 c8ebcc18ba7b44aef8fada3f9fea88fdaaf6bae12cf809b08f98e85ab6396ae032bfd7706809cd266be67c694749d4364a9cc591eb750478e095cbbcbe061419
AUX libgpod-0.8.3-segfault.patch 1171 BLAKE2B ae8f00ad8708f23ef83c9f03f5e9a7157c2bdeaf0cfa2ed4542f8cc96295dad0200e968cb180883efa0e93fd180088be84fa0d2f1b40c642ada0caf37f7f3b9a SHA512 9b2f9a4f4e8f41e5d11cbc943cbba915147b81ec66859b62a5986b5d1c5c90526ce522e24499daf3378c201126ac6e5da8ef855a5f2353b933806c5b3aa6effb
DIST libgpod-0.8.3.tar.bz2 801903 BLAKE2B e9bc54d23be7f54a17eea3f8a07d7bf6a28224d9c0b0f90fb9d44d97af6cf64c31096de5d9fa4b446e1a9463a6e8f3a59929d73bf52ad8d638732868c3c1b7d0 SHA512 e39f22054c2d2bdf5fc764aa1f692de17a1a06c7c7e9c60883d126b216dacca7840bf818e7e7e039218fe2a64c0920ba96d8cbbe310e11c1c4e68b82e7cbbd8e
EBUILD libgpod-0.8.3-r5.ebuild 1449 BLAKE2B e059e7023637550c93bf22c2fa234c30945a95dac0617217cd2f8ff5e3db20ebb40d48bf8b991a1622c42fcdb4d0b43cb05a74784604a7f4f49e40c9d363a80f SHA512 95ba31e85a5f89faebe5d6fcf47e1abfbb41a3a14644db8e101bdc8bd4cc04f7adf5b71781ebdf2f07de0e66478d180c201a538ad39a0e5fc5ccf199fc8b6151
+EBUILD libgpod-0.8.3-r6.ebuild 1591 BLAKE2B 902ff0bef6b07d40ad0e7ff34b3401e266847a056eec0fedf06309331a4d46d3d22705b89d0a00a21011d7649574338589c4d8d9894dfdd3929ee74c8110fbad SHA512 836f1b36a48fdb9f442ae68dfeb9a9843ea650f62121be947952833ab4ec62a4c6bffca8460f23037a1a99019ee925bf1fb3f0d5e4f4795f5902c030462518b5
MISC metadata.xml 484 BLAKE2B f3704943d01d8048940f1d359a12330aad167f6a7b3e67f37fd3c8b954aef0cde441b3e9b957414404e5a450a21acb899a8c07df838632063e45734cebea1b68 SHA512 40128d4bd5043e699ec2acdbc267eba5f2ca4cb54e7e05ca81d033fee88124e37824234ddfe2d51da7cbbb2757cb68801db4899c82c66895e5005bd85a211965
diff --git a/media-libs/libgpod/files/libgpod-0.8.3-implicit-int.patch b/media-libs/libgpod/files/libgpod-0.8.3-implicit-int.patch
new file mode 100644
index 000000000000..91219dd64a4f
--- /dev/null
+++ b/media-libs/libgpod/files/libgpod-0.8.3-implicit-int.patch
@@ -0,0 +1,19 @@
+Clang16 will not allow implicit integers by default.
+
+Bug: https://bugs.gentoo.org/885349
+Patch has been sent upstream here: https://sourceforge.net/p/gtkpod/patches/47/
+
+Pascal Jäger <pascal.jaeger@leimstift.de> (2022-12-11)
+
+--- a/tools/generic-callout.c
++++ b/tools/generic-callout.c
+@@ -663,8 +663,7 @@ static gboolean write_sysinfo_extended (const char *mountpoint,
+ return success;
+ }
+
+-
+-static char *get_info_from_usb (usb_bus_number, usb_device_number)
++static char *get_info_from_usb (guint usb_bus_number,guint usb_device_number)
+ {
+ #ifdef HAVE_LIBUSB
+ return read_sysinfo_extended_from_usb (usb_bus_number,
diff --git a/media-libs/libgpod/libgpod-0.8.3-r6.ebuild b/media-libs/libgpod/libgpod-0.8.3-r6.ebuild
new file mode 100644
index 000000000000..32255f4daaf5
--- /dev/null
+++ b/media-libs/libgpod/libgpod-0.8.3-r6.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools udev
+
+DESCRIPTION="Shared library to access the contents of an iPod"
+HOMEPAGE="http://www.gtkpod.org/libgpod/"
+SRC_URI="mirror://sourceforge/gtkpod/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+IUSE="+gtk ios +udev"
+
+RDEPEND="
+ >=app-pda/libplist-1.0:=
+ >=dev-db/sqlite-3:3
+ >=dev-libs/glib-2.16:2
+ dev-libs/libxml2:2
+ sys-apps/sg3_utils:0=
+ gtk? ( x11-libs/gdk-pixbuf:2 )
+ ios? ( app-pda/libimobiledevice:= )
+ udev? ( virtual/udev )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxslt
+ dev-util/intltool
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS NEWS README{,.overview,.sqlite,.SysInfo} TROUBLESHOOTING )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-comment.patch # bug 537968
+ "${FILESDIR}"/${P}-segfault.patch # bug 565052
+ "${FILESDIR}"/${P}-pkgconfig_overlinking.patch
+ "${FILESDIR}"/${P}-implicit-int.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-pygobject
+ --disable-static
+ --without-hal
+ --without-mono
+ --without-python
+ --with-udev-dir="$(get_udevdir)"
+ $(use_enable gtk gdk-pixbuf)
+ $(use_with ios libimobiledevice)
+ $(use_enable udev)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ rm "${ED}"/usr/$(get_libdir)/pkgconfig/libgpod-sharp.pc || die
+ use udev && rmdir "${ED}"/tmp || die
+ find "${ED}" -name '*.la' -type f -delete || die
+}
+
+pkg_postinst() {
+ use udev && udev_reload
+}
+
+pkg_postrm() {
+ use udev && udev_reload
+}