summaryrefslogtreecommitdiff
path: root/media-libs/libglvnd/libglvnd-1.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libglvnd/libglvnd-1.1.1.ebuild')
-rw-r--r--media-libs/libglvnd/libglvnd-1.1.1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/media-libs/libglvnd/libglvnd-1.1.1.ebuild b/media-libs/libglvnd/libglvnd-1.1.1.ebuild
deleted file mode 100644
index 89d10684b842..000000000000
--- a/media-libs/libglvnd/libglvnd-1.1.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2018-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGIT_REPO_URI="https://github.com/NVIDIA/${PN}.git"
-
-if [[ ${PV} = 9999* ]]; then
- GIT_ECLASS="git-r3"
-fi
-
-PYTHON_COMPAT=( python2_7 )
-inherit autotools ${GIT_ECLASS} multilib-minimal python-any-r1
-
-DESCRIPTION="The GL Vendor-Neutral Dispatch library"
-HOMEPAGE="https://github.com/NVIDIA/libglvnd"
-if [[ ${PV} = 9999* ]]; then
- SRC_URI=""
-else
- KEYWORDS="~amd64"
- SRC_URI="https://github.com/NVIDIA/${PN}/releases/download/v${PV}/${P}.tar.gz"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- !media-libs/mesa[-libglvnd(-)]
- x11-libs/libX11[${MULTILIB_USEDEP}]
- "
-DEPEND="${PYTHON_DEPS}
- ${RDEPEND}"
-
-src_prepare() {
- default
- [[ $PV = 9999* ]] && eautoreconf
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} econf
-}
-
-multilib_src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}
-
-multilib_src_test() {
- emake check
-}