summaryrefslogtreecommitdiff
path: root/media-libs/libfishsound/libfishsound-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libfishsound/libfishsound-1.0.0.ebuild')
-rw-r--r--media-libs/libfishsound/libfishsound-1.0.0.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/media-libs/libfishsound/libfishsound-1.0.0.ebuild b/media-libs/libfishsound/libfishsound-1.0.0.ebuild
deleted file mode 100644
index 3422916b0400..000000000000
--- a/media-libs/libfishsound/libfishsound-1.0.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Simple programming interface to decode and encode audio with vorbis or speex"
-HOMEPAGE="https://www.xiph.org/fishsound/"
-SRC_URI="https://downloads.xiph.org/releases/libfishsound/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="flac speex"
-
-RDEPEND="
- media-libs/libogg
- media-libs/libvorbis
- flac? ( media-libs/flac )
- speex? ( media-libs/speex )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-# bug #395153
-RESTRICT="test"
-
-PATCHES=( "${FILESDIR}"/${P}-pc.patch )
-
-src_prepare() {
- default
- sed -i \
- -e 's:doxygen:doxygen-dummy:' \
- configure || die
-}
-
-src_configure() {
- local myconf="--disable-static"
- use flac || myconf="${myconf} --disable-flac"
- use speex || myconf="${myconf} --disable-speex"
-
- econf ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" \
- docdir="${D}/usr/share/doc/${PF}" install
- dodoc AUTHORS ChangeLog README
- find "${ED}" -name '*.la' -delete || die
-}