summaryrefslogtreecommitdiff
path: root/media-libs/libdvdread
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libdvdread')
-rw-r--r--media-libs/libdvdread/Manifest4
-rw-r--r--media-libs/libdvdread/libdvdread-6.1.3.ebuild49
-rw-r--r--media-libs/libdvdread/libdvdread-9999.ebuild17
3 files changed, 63 insertions, 7 deletions
diff --git a/media-libs/libdvdread/Manifest b/media-libs/libdvdread/Manifest
index 06525588ff8e..474059c1c05e 100644
--- a/media-libs/libdvdread/Manifest
+++ b/media-libs/libdvdread/Manifest
@@ -1,4 +1,6 @@
DIST libdvdread-6.1.2.tar.bz2 391536 BLAKE2B 870f8c2bba7f1a1c0f6a010c0a75517b488a466186f76f752c67e16f87b55d8fc9450aeaa69d044b42b6a26a2fc51297290be301f5a449b4b8269f6c812f35cd SHA512 5cbee11ec701b7625d71184fd712de48a129f235b08797b499d0f5b06a1c73bfec1d0e52e897585017ab63b1d81b042257eab5ab1f19fb340b05b3e8d794f86c
+DIST libdvdread-6.1.3.tar.bz2 395439 BLAKE2B 7a8c0b69692059d51a9d94fc4c934f8259c2aa71ac9a9e6d5da22b3668fcbdf000c47fbc7fdb1257f65b90b4d8a4733e01fc2936033246cf2c6a5b68fef81647 SHA512 c98055829ccbbe2bb7b5df48f6e279cf6e91ecab39a35c37081581452f7df7531c1d7b8abd641c55eeee357235b2658b31478dbc307995cffdf8c011bd0dd0bc
EBUILD libdvdread-6.1.2.ebuild 1159 BLAKE2B e261dc67a127951b589f73db2b4c6f929b3729a120e4f1f3b94d21c4e5251fd39f624acf968ed8b70b1b02443017bebdd08fc0b41814f79e1d8df35e1b86e697 SHA512 6c47b5d9ca1fe9727a6829605d5c284f425df1c5f51bdcc35cf8658972a596f1785317cdd9b20c18b34c0b9005c0a7bb39910385540d83b045c2bf83cf0ae596
-EBUILD libdvdread-9999.ebuild 1159 BLAKE2B c20416ea4b21ca2bea20b563ed49cb9f2a0697b30d21b79576950274d77618ad6ce29d36a33e444af94d5f55e042130e129939abc34979b25b8905b01d991fee SHA512 d63372b5c05eaa80efa1faf8f5f811a35ba1de3bb05d744003c8cb62938fa8cbea7f2a2a4e63ed10ddf3a72545bc2564d59f2dac98fc8b5bf876ad99b414ec7e
+EBUILD libdvdread-6.1.3.ebuild 1223 BLAKE2B 337ae012a55df8745fbe9ee70efb9e8203bac75fe2515af9f8e0bc0642df951620a98601ae79e613b1ad5f968a461384dad4e93b461536ade97ca31ec025feb0 SHA512 d7970ac602ee51d9af26fb141e67382bc6cff417e0a637f4af1249290e4859d030fef5e90146ec3a4910564e253b1ec0cdffd7ac47e0235e01af3efc3a25f059
+EBUILD libdvdread-9999.ebuild 1223 BLAKE2B 337ae012a55df8745fbe9ee70efb9e8203bac75fe2515af9f8e0bc0642df951620a98601ae79e613b1ad5f968a461384dad4e93b461536ade97ca31ec025feb0 SHA512 d7970ac602ee51d9af26fb141e67382bc6cff417e0a637f4af1249290e4859d030fef5e90146ec3a4910564e253b1ec0cdffd7ac47e0235e01af3efc3a25f059
MISC metadata.xml 222 BLAKE2B 96fcf0d83a18e2c1f4611d550e7e2123a06fe8b3b2890cb5757284d8fc7d3bebdf1aeb4f82affbc7c51268749cac9fdcbf43888e3bec0e68e1b6548a3f6eca76 SHA512 c3657a6bf2503e6585ee53453bf0ba26b5eed2e894342087358b5f4306a960db915de61036b6c8dc57cdb7a7f3326d57ff3badf7b3ecefaa99291289a73997de
diff --git a/media-libs/libdvdread/libdvdread-6.1.3.ebuild b/media-libs/libdvdread/libdvdread-6.1.3.ebuild
new file mode 100644
index 000000000000..6efa7014e58d
--- /dev/null
+++ b/media-libs/libdvdread/libdvdread-6.1.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="Library for DVD navigation tools"
+HOMEPAGE="https://www.videolan.org/developers/libdvdnav.html"
+if [[ ${PV} = 9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://code.videolan.org/videolan/libdvdread.git"
+else
+ SRC_URI="https://downloads.videolan.org/pub/videolan/libdvdread/${PV}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/8" # libdvdread.so.VERSION
+IUSE="+css static-libs"
+
+RDEPEND="css? ( >=media-libs/libdvdcss-1.3.0[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS TODO README )
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ --disable-apidoc
+ $(use_enable static-libs static)
+ $(use_with css libdvdcss)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name "*.la" -delete || die
+}
diff --git a/media-libs/libdvdread/libdvdread-9999.ebuild b/media-libs/libdvdread/libdvdread-9999.ebuild
index 7eb3ec37c638..6efa7014e58d 100644
--- a/media-libs/libdvdread/libdvdread-9999.ebuild
+++ b/media-libs/libdvdread/libdvdread-9999.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools multilib-minimal
+inherit multilib-minimal
DESCRIPTION="Library for DVD navigation tools"
HOMEPAGE="https://www.videolan.org/developers/libdvdnav.html"
if [[ ${PV} = 9999 ]]; then
- inherit git-r3
+ inherit autotools git-r3
EGIT_REPO_URI="https://code.videolan.org/videolan/libdvdread.git"
else
SRC_URI="https://downloads.videolan.org/pub/videolan/libdvdread/${PV}/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
fi
LICENSE="GPL-2"
@@ -27,15 +27,20 @@ DOCS=( AUTHORS ChangeLog NEWS TODO README )
src_prepare() {
default
- eautoreconf
+
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
}
multilib_src_configure() {
local myeconfargs=(
--enable-shared
+ --disable-apidoc
$(use_enable static-libs static)
$(use_with css libdvdcss)
)
+
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}