summaryrefslogtreecommitdiff
path: root/media-libs/libbsb/libbsb-0.0.7-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libbsb/libbsb-0.0.7-r2.ebuild')
-rw-r--r--media-libs/libbsb/libbsb-0.0.7-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/libbsb/libbsb-0.0.7-r2.ebuild b/media-libs/libbsb/libbsb-0.0.7-r2.ebuild
new file mode 100644
index 000000000000..be7212a192b1
--- /dev/null
+++ b/media-libs/libbsb/libbsb-0.0.7-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Portable C library for reading and writing BSB format image files"
+HOMEPAGE="https://libbsb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="media-libs/libpng
+ media-libs/tiff:="
+RDEPEND="${DEPEND}"
+
+# "make check" in 0.0.7 fails with newer tiff versions (4.0.0) altough the
+# tools work perfectly, so restrict test until this is fixed upstream
+RESTRICT="test"
+
+src_prepare(){
+ sed -i -e "s|ar crv|$(tc-getAR) crv|" Makefile.am || die
+ default
+ eautoreconf
+}