summaryrefslogtreecommitdiff
path: root/media-libs/gst-plugins-good/gst-plugins-good-1.22.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gst-plugins-good/gst-plugins-good-1.22.11.ebuild')
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-1.22.11.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-1.22.11.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-1.22.11.ebuild
new file mode 100644
index 000000000000..736d51613f44
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-1.22.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GST_ORG_MODULE="gst-plugins-good"
+
+inherit gstreamer-meson
+
+DESCRIPTION="Basepack of plugins for GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+orc"
+
+# Old media-libs/gst-plugins-ugly blocker for xingmux moving from ugly->good
+RDEPEND="
+ !<media-libs/gst-plugins-ugly-1.22.3
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.33[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md RELEASE )
+
+multilib_src_configure() {
+ # gst/matroska can use bzip2
+ GST_PLUGINS_NOAUTO="bz2"
+
+ local emesonargs=(
+ -Dbz2=enabled
+ )
+
+ gstreamer_multilib_src_configure
+}