summaryrefslogtreecommitdiff
path: root/media-libs/glu/glu-9.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/glu/glu-9.0.2.ebuild')
-rw-r--r--media-libs/glu/glu-9.0.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/glu/glu-9.0.2.ebuild b/media-libs/glu/glu-9.0.2.ebuild
new file mode 100644
index 000000000000..978531ce2bb7
--- /dev/null
+++ b/media-libs/glu/glu-9.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/glu.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit meson-multilib ${GIT_ECLASS}
+
+DESCRIPTION="The OpenGL Utility Library"
+HOMEPAGE="https://gitlab.freedesktop.org/mesa/glu"
+
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://mesa.freedesktop.org/archive/glu/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="SGI-B-2.0"
+SLOT="0"
+IUSE="static-libs"
+
+DEPEND=">=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library=$(usex static-libs both shared)
+ -Dgl_provider=glvnd
+ )
+ meson_src_configure
+}