summaryrefslogtreecommitdiff
path: root/media-libs/glm/glm-0.9.9.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/glm/glm-0.9.9.8.ebuild')
-rw-r--r--media-libs/glm/glm-0.9.9.8.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/glm/glm-0.9.9.8.ebuild b/media-libs/glm/glm-0.9.9.8.ebuild
new file mode 100644
index 000000000000..dcd6a2c59118
--- /dev/null
+++ b/media-libs/glm/glm-0.9.9.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="OpenGL Mathematics"
+HOMEPAGE="http://glm.g-truc.net/"
+SRC_URI="https://github.com/g-truc/glm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( HappyBunny MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_avx cpu_flags_x86_avx2"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.9.6-simd.patch
+)
+
+src_prepare() {
+ sed \
+ -e "s:@CMAKE_INSTALL_PREFIX@:${EPREFIX}/usr:" \
+ -e "s:@GLM_VERSION@:0.9.9:" \
+ "${FILESDIR}"/glm.pc.in \
+ > glm.pc
+ cmake_src_prepare
+}
+
+src_configure() {
+ if use test; then
+ local mycmakeargs=(
+ -DGLM_TEST_ENABLE=ON
+ -DGLM_TEST_ENABLE_SIMD_SSE2="$(usex cpu_flags_x86_sse2 ON OFF)"
+ -DGLM_TEST_ENABLE_SIMD_SSE3="$(usex cpu_flags_x86_sse3 ON OFF)"
+ -DGLM_TEST_ENABLE_SIMD_AVX="$(usex cpu_flags_x86_avx ON OFF)"
+ -DGLM_TEST_ENABLE_SIMD_AVX2="$(usex cpu_flags_x86_avx2 ON OFF)"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+src_install() {
+ doheader -r glm
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins glm.pc
+ dodoc readme.md manual.md
+}