summaryrefslogtreecommitdiff
path: root/media-libs/glm/glm-0.9.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/glm/glm-0.9.9.1.ebuild')
-rw-r--r--media-libs/glm/glm-0.9.9.1.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/media-libs/glm/glm-0.9.9.1.ebuild b/media-libs/glm/glm-0.9.9.1.ebuild
deleted file mode 100644
index 8f93505e3279..000000000000
--- a/media-libs/glm/glm-0.9.9.1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="OpenGL Mathematics"
-HOMEPAGE="http://glm.g-truc.net/"
-SRC_URI="https://github.com/g-truc/glm/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( HappyBunny MIT )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE="test cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_avx cpu_flags_x86_avx2"
-
-RDEPEND="virtual/opengl"
-
-src_configure() {
- if use test; then
- local mycmakeargs=(
- -DGLM_TEST_ENABLE=ON
- -DGLM_TEST_ENABLE_SIMD_SSE2="$(usex cpu_flags_x86_sse2 ON OFF)"
- -DGLM_TEST_ENABLE_SIMD_SSE3="$(usex cpu_flags_x86_sse3 ON OFF)"
- -DGLM_TEST_ENABLE_SIMD_AVX="$(usex cpu_flags_x86_avx ON OFF)"
- -DGLM_TEST_ENABLE_SIMD_AVX2="$(usex cpu_flags_x86_avx2 ON OFF)"
- )
- fi
-
- cmake-utils_src_configure
-}