summaryrefslogtreecommitdiff
path: root/media-libs/elgato-streamdeck
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/elgato-streamdeck')
-rw-r--r--media-libs/elgato-streamdeck/Manifest4
-rw-r--r--media-libs/elgato-streamdeck/elgato-streamdeck-0.8.1.ebuild25
-rw-r--r--media-libs/elgato-streamdeck/elgato-streamdeck-9999.ebuild25
-rw-r--r--media-libs/elgato-streamdeck/metadata.xml11
4 files changed, 65 insertions, 0 deletions
diff --git a/media-libs/elgato-streamdeck/Manifest b/media-libs/elgato-streamdeck/Manifest
new file mode 100644
index 000000000000..6aac3033d2b7
--- /dev/null
+++ b/media-libs/elgato-streamdeck/Manifest
@@ -0,0 +1,4 @@
+DIST elgato-streamdeck-0.8.1.tar.gz 2552919 BLAKE2B 505a7ad71b04473b3eb2c719304c224829ebf5abc366bea0d38daf882099d92308b1099815435ac03f65542bdb908a2cafbdc96f10168351fd06644050b69f06 SHA512 c65b90ab0ee5c6e17a6f7af670c54a12c96b705ef4bec359a51ba6671a3908626a9658f5a5829266102fa249628b82ee04c525db995f4984f26f802620598e6c
+EBUILD elgato-streamdeck-0.8.1.ebuild 678 BLAKE2B 27bcf7be0cb80a4a5e0bf7dd6d53eb1cf0b5dbeca0af5881fe13de907fa86cb3c1759d65a6c2b59148310e6d35bb8b40c63ee86fea1e52a23297fa249261d0f1 SHA512 780bff4e526982e83803b69d9dc4809dcc589c3aeaded440c10bdaaec4f13a9658f4ef18b9cc0b8cada02e3defc9a549331d6d6d7354f3dd30e8f8b817c20968
+EBUILD elgato-streamdeck-9999.ebuild 678 BLAKE2B 27bcf7be0cb80a4a5e0bf7dd6d53eb1cf0b5dbeca0af5881fe13de907fa86cb3c1759d65a6c2b59148310e6d35bb8b40c63ee86fea1e52a23297fa249261d0f1 SHA512 780bff4e526982e83803b69d9dc4809dcc589c3aeaded440c10bdaaec4f13a9658f4ef18b9cc0b8cada02e3defc9a549331d6d6d7354f3dd30e8f8b817c20968
+MISC metadata.xml 348 BLAKE2B cb56a80dd311cb9182715619ad17b40dc832adbc3800410aa788684b39890f164eccc98025616ea42ed6098cb7bdf5de2b074d04cd8ed89a71ba7a9b427b63e2 SHA512 95599f43d0440d499b92acb9fe90f1e93514672aec977f7be692e1957be3b255c18a3b0e54eebfa1b80868fd34c1141376a2ff10316e371fe4c55c2cdad0d60e
diff --git a/media-libs/elgato-streamdeck/elgato-streamdeck-0.8.1.ebuild b/media-libs/elgato-streamdeck/elgato-streamdeck-0.8.1.ebuild
new file mode 100644
index 000000000000..07a7469b980d
--- /dev/null
+++ b/media-libs/elgato-streamdeck/elgato-streamdeck-0.8.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python library to control the Elgato Stream Deck"
+HOMEPAGE="https://github.com/abcminiuser/python-elgato-streamdeck"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/abcminiuser/python-elgato-streamdeck.git"
+else
+ SRC_URI="https://github.com/abcminiuser/python-elgato-streamdeck/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/python-${P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
diff --git a/media-libs/elgato-streamdeck/elgato-streamdeck-9999.ebuild b/media-libs/elgato-streamdeck/elgato-streamdeck-9999.ebuild
new file mode 100644
index 000000000000..07a7469b980d
--- /dev/null
+++ b/media-libs/elgato-streamdeck/elgato-streamdeck-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python library to control the Elgato Stream Deck"
+HOMEPAGE="https://github.com/abcminiuser/python-elgato-streamdeck"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/abcminiuser/python-elgato-streamdeck.git"
+else
+ SRC_URI="https://github.com/abcminiuser/python-elgato-streamdeck/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/python-${P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
diff --git a/media-libs/elgato-streamdeck/metadata.xml b/media-libs/elgato-streamdeck/metadata.xml
new file mode 100644
index 000000000000..06283887ab24
--- /dev/null
+++ b/media-libs/elgato-streamdeck/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">abcminiuser/python-elgato-streamdeck</remote-id>
+ </upstream>
+</pkgmetadata>