summaryrefslogtreecommitdiff
path: root/media-libs/codec2/codec2-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/codec2/codec2-1.0.0.ebuild')
-rw-r--r--media-libs/codec2/codec2-1.0.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-libs/codec2/codec2-1.0.0.ebuild b/media-libs/codec2/codec2-1.0.0.ebuild
new file mode 100644
index 000000000000..b90705d61a95
--- /dev/null
+++ b/media-libs/codec2/codec2-1.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Low bit rate speech codec"
+HOMEPAGE="https://freedv.org/ https://www.rowetel.com/?page_id=452 https://github.com/drowe67/codec2"
+SRC_URI="https://github.com/drowe67/codec2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples test"
+# Not yet passing, but infrastructure added to run
+RESTRICT="test"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DUNITTEST=$(usex test)
+ -DINSTALL_EXAMPLES=$(usex examples)
+ )
+ cmake_src_configure
+}