summaryrefslogtreecommitdiff
path: root/media-libs/cimg/cimg-2.7.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/cimg/cimg-2.7.2.ebuild')
-rw-r--r--media-libs/cimg/cimg-2.7.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-libs/cimg/cimg-2.7.2.ebuild b/media-libs/cimg/cimg-2.7.2.ebuild
new file mode 100644
index 000000000000..a3f01bc9ba22
--- /dev/null
+++ b/media-libs/cimg/cimg-2.7.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C++ template image processing toolkit"
+HOMEPAGE="https://cimg.eu/ https://github.com/dtschump/CImg"
+SRC_URI="https://github.com/dtschump/CImg/archive/v.${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CeCILL-2 CeCILL-C"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+S=${WORKDIR}/CImg-v.${PV}
+
+src_install() {
+ doheader CImg.h
+ dodoc README.txt
+
+ use doc && dodoc -r html
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}