summaryrefslogtreecommitdiff
path: root/media-gfx/zbar/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/zbar/files')
-rw-r--r--media-gfx/zbar/files/zbar-0.23.90-fix-gtk-default.patch35
-rw-r--r--media-gfx/zbar/files/zbar-0.23.90-fix-qt5x11extras-detect.patch18
-rw-r--r--media-gfx/zbar/files/zbar-0.23.90-fix-unittest.patch78
3 files changed, 131 insertions, 0 deletions
diff --git a/media-gfx/zbar/files/zbar-0.23.90-fix-gtk-default.patch b/media-gfx/zbar/files/zbar-0.23.90-fix-gtk-default.patch
new file mode 100644
index 000000000000..b1316243dd24
--- /dev/null
+++ b/media-gfx/zbar/files/zbar-0.23.90-fix-gtk-default.patch
@@ -0,0 +1,35 @@
+From 468f6bda627d683b3f40dbaf242c158409666f7e Mon Sep 17 00:00:00 2001
+From: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
+Date: Sat, 13 Mar 2021 18:04:57 +0100
+Subject: [PATCH] configure.ac: fix some issues with gtk parameter
+
+By default, it uses Gtk3. Also, the with_gtk set to "no"
+is wrong.
+
+Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index b6f87531..30a59f72 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -492,7 +492,7 @@ AS_IF([test "x$with_npapi" != "xno"],
+ AM_CONDITIONAL([HAVE_NPAPI], [test "x$with_npapi" = "xyes"])
+
+ dnl GTK
+-dnl For now, defaults to GTK version 2
++dnl For now, defaults to GTK version 3
+
+ AC_ARG_WITH([gtk],
+ [AS_HELP_STRING([--with-gtk],
+@@ -500,7 +500,7 @@ AC_ARG_WITH([gtk],
+ [AS_IF([test "x$with_gtk" != "xno" && test "x$with_gtk" != "xauto" &&
+ test "x$with_gtk" != "xgtk2" && test "x$with_gtk" != "xgtk3"],
+ [echo "Invalid value for --with-gtk. Falling back to 'no'"
+- with_gtk="xno"])],
++ with_gtk="no"])],
+ [with_gtk="auto"])
+
+ AC_ARG_VAR([GLIB_GENMARSHAL], [full path to glib-genmarshal])
diff --git a/media-gfx/zbar/files/zbar-0.23.90-fix-qt5x11extras-detect.patch b/media-gfx/zbar/files/zbar-0.23.90-fix-qt5x11extras-detect.patch
new file mode 100644
index 000000000000..e8f6357eb486
--- /dev/null
+++ b/media-gfx/zbar/files/zbar-0.23.90-fix-qt5x11extras-detect.patch
@@ -0,0 +1,18 @@
+diff -ur a/configure.ac b/configure.ac
+--- a/configure.ac 2019-05-23 23:37:12.000000000 +0300
++++ b/configure.ac 2020-01-22 12:27:14.190755156 +0300
+@@ -638,13 +638,9 @@
+
+ AC_ARG_VAR([MOC], [full path to Qt moc program])
+
+-AS_IF([test "x$have_x" = "xyes"],
+- [qt_extra="Qt5X11Extras >= 5.0"],
+- [qt_extra=""])
+-
+ AS_IF([test "x$with_qt" != "xno"],
+ [PKG_CHECK_MODULES([QT],
+- [Qt5Core >= 5 Qt5Gui >= 5 Qt5Widgets >= 5.0 $qt_extra],,
++ [Qt5Core >= 5 Qt5Gui >= 5 Qt5Widgets >= 5.0 Qt5X11Extras >= 5.0],,
+ [with_qt5="no"
+ PKG_CHECK_MODULES([QT],
+ [QtCore >= 4 QtGui >= 4],,
diff --git a/media-gfx/zbar/files/zbar-0.23.90-fix-unittest.patch b/media-gfx/zbar/files/zbar-0.23.90-fix-unittest.patch
new file mode 100644
index 000000000000..589ebd4e287c
--- /dev/null
+++ b/media-gfx/zbar/files/zbar-0.23.90-fix-unittest.patch
@@ -0,0 +1,78 @@
+diff -ur a/configure.ac b/configure.ac
+--- a/configure.ac 2020-04-21 00:09:21.000000000 +0300
++++ b/configure.ac 2020-04-23 16:53:06.654339488 +0300
+@@ -336,6 +336,14 @@
+ AC_SUBST(DBUS_CONFDIR)
+ ])
+
++dnl zbarimg tests
++AC_ARG_WITH([zbarimg_tests],
++ [AS_HELP_STRING([--without-zbarimg-tests],
++ [disable tests for zbarimg])],
++ [],
++ [with_zbarimg_tests="yes"])
++AM_CONDITIONAL([HAVE_ZBARIMG_TESTS], [test "x$with_zbarimg_tests" = "xyes"])
++
+ dnl libjpeg
+ AC_ARG_WITH([jpeg],
+ [AS_HELP_STRING([--without-jpeg],
+@@ -724,25 +732,12 @@
+
+ AC_ARG_VAR([CLASSPATH], [Java class path (include JUnit to run java tests)])
+ AS_IF([test "x$CLASSPATH" = "x"], [CLASSPATH="."])
++AC_SUBST(CLASSPATH)
+
+-dnl Search for Java unit test library
+-AS_IF([test -z "$JUNIT_HOME"],
+- [JUNIT_HOME="/usr/share/java"])
+-
+-AS_IF([test -f "$JUNIT_HOME/junit4.jar"],
+- [JUNIT="$JUNIT_HOME/junit4.jar"],
+- [AS_IF([test -f "$JUNIT_HOME/junit.jar"],
+- [JUNIT="$JUNIT_HOME/junit.jar"])])
+-
+-AS_IF([test "x$JUNIT" != "x"],
+- [AS_IF([test -f "/usr/share/java/hamcrest/all.jar"],
+- [CLASSPATH="$JUNIT:/usr/share/java/hamcrest/all.jar:$CLASSPATH"
+- AC_SUBST(CLASSPATH)
+- with_java_unit="yes"])],
+- [AS_IF([test -f "/usr/share/java/hamcrest-all.jar"],
+- [CLASSPATH="$JUNIT:/usr/share/java/hamcrest-all.jar:$CLASSPATH"
+- AC_SUBST(CLASSPATH)
+- with_java_unit="yes"])])
++AC_ARG_WITH([java_unit],
++ [AS_HELP_STRING([--without-java-unit],
++ [Enable java unittest])],
++ [with_java_unit="yes"])
+
+ AM_CONDITIONAL([HAVE_JAVA_UNIT], [test "x$with_java_unit" = "xyes"])
+
+@@ -905,6 +900,8 @@
+ [echo " => the Java interface will *NOT* be built"])
+ AS_IF([test "x$with_java_unit" != "xyes"],
+ [echo " => the Java unit test will *NOT* be enabled"])
++AS_IF([test "x$with_zbarimg_tests" != "xyes"],
++ [echo " => zbarimg tests will *NOT* be enabled"])
+ dnl echo "NPAPI Plugin --with-npapi=$with_npapi"
+ dnl AS_IF([test "x$with_mozilla" != "xyes"],
+ dnl [echo " => the Mozilla/Firefox/OpenOffice plugin will *NOT* be built"])
+diff -ur a/test/Makefile.am.inc b/test/Makefile.am.inc
+--- a/test/Makefile.am.inc 2020-04-21 00:09:21.000000000 +0300
++++ b/test/Makefile.am.inc 2020-04-23 17:03:07.819999370 +0300
+@@ -91,11 +91,16 @@
+ regress-decoder: test/test_decode
+ @abs_top_builddir@/test/test_decode -q -n 100000
+
++if HAVE_ZBARIMG_TESTS
+ check-images-py: zbarimg/zbarimg
+ @PYTHON@ @abs_top_srcdir@/test/barcodetest.py
+
+ check-images: zbarimg/zbarimg
+ @abs_top_builddir@/test/test_examples.sh
++else
++check-images-py:
++check-images:
++endif
+
+ check-convert: test/test_convert
+ @abs_top_srcdir@/test/test_convert