summaryrefslogtreecommitdiff
path: root/media-gfx/ufraw/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/ufraw/files')
-rw-r--r--media-gfx/ufraw/files/ufraw-0.17-cfitsio-automagic.patch28
-rw-r--r--media-gfx/ufraw/files/ufraw-0.22-CVE-2015-8366.patch17
-rw-r--r--media-gfx/ufraw/files/ufraw-0.22-CVE-2018-19655.patch44
-rw-r--r--media-gfx/ufraw/files/ufraw-0.22-crashfix.patch15
-rw-r--r--media-gfx/ufraw/files/ufraw-0.22-drop_superfluous_abs.patch16
-rw-r--r--media-gfx/ufraw/files/ufraw-0.22-exiv2-0.27.patch26
-rw-r--r--media-gfx/ufraw/files/ufraw-0.22-fix-unsigned-char.patch20
-rw-r--r--media-gfx/ufraw/files/ufraw-0.22-gcc9.patch97
-rw-r--r--media-gfx/ufraw/files/ufraw-0.22-glib-2.68.patch19
-rw-r--r--media-gfx/ufraw/files/ufraw-0.22-jasper-automagic.patch21
-rw-r--r--media-gfx/ufraw/files/ufraw-0.22-jpeg9.patch32
11 files changed, 0 insertions, 335 deletions
diff --git a/media-gfx/ufraw/files/ufraw-0.17-cfitsio-automagic.patch b/media-gfx/ufraw/files/ufraw-0.17-cfitsio-automagic.patch
deleted file mode 100644
index aff7c5a25930..000000000000
--- a/media-gfx/ufraw/files/ufraw-0.17-cfitsio-automagic.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -ru ufraw-0.17.orig/configure.ac ufraw-0.17/configure.ac
---- ufraw-0.17.orig/configure.ac 2010-04-02 16:16:08.000000000 +0200
-+++ ufraw-0.17/configure.ac 2010-04-02 16:19:33.000000000 +0200
-@@ -246,11 +246,19 @@
- [ have_png=no
- AC_MSG_RESULT($LIBPNG_PKG_ERRORS) ] )
-
--PKG_CHECK_MODULES(CFITSIO, cfitsio,
-- [ have_cfitsio=yes
-- AC_DEFINE(HAVE_LIBCFITSIO, 1, have the cfitsio library) ],
-- [ have_cfitsio=no
-- AC_MSG_RESULT($CFITSIO_PKG_ERRORS) ] )
-+AC_ARG_WITH([cfitsio],
-+ [AS_HELP_STRING([--with-cfitsio],
-+ [build fits support @<:@default=check@:>@])],
-+ [],
-+ [with_cfitsio=check])
-+
-+have_cfitsio=no
-+AS_IF([test "x$with_cfitsio" != xno],
-+ [PKG_CHECK_MODULES(CFITSIO, cfitsio,
-+ [ have_cfitsio=yes
-+ AC_DEFINE(HAVE_LIBCFITSIO, 1, have the cfitsio library) ],
-+ [ have_cfitsio=no
-+ AC_MSG_RESULT($CFITSIO_PKG_ERRORS) ] ) ] )
-
- PKG_CHECK_MODULES(EXIV2, exiv2 >= 0.16,
- [ have_exiv2=yes
diff --git a/media-gfx/ufraw/files/ufraw-0.22-CVE-2015-8366.patch b/media-gfx/ufraw/files/ufraw-0.22-CVE-2015-8366.patch
deleted file mode 100644
index 9d59ca413fbe..000000000000
--- a/media-gfx/ufraw/files/ufraw-0.22-CVE-2015-8366.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Fix a buffer overflow bug. See
-https://github.com/LibRaw/LibRaw/commit/89d065424f09b788f443734d44857289489ca9e2
-
---- a/dcraw.cc
-+++ b/dcraw.cc
-@@ -3013,7 +3013,10 @@
- diff = diff ? -diff : 0x80;
- if (ftell(ifp) + 12 >= (int) seg[1][1])
- diff = 0;
-- raw_image[pix] = pred[pix & 1] += diff;
-+ if(pix>=raw_width*raw_height)
-+ derror();
-+ else
-+ raw_image[pix] = pred[pix & 1] += diff;
- if (!(pix & 1) && HOLE(pix / raw_width)) pix += 2;
- }
- maximum = 0xff;
diff --git a/media-gfx/ufraw/files/ufraw-0.22-CVE-2018-19655.patch b/media-gfx/ufraw/files/ufraw-0.22-CVE-2018-19655.patch
deleted file mode 100644
index 78b46b4452e0..000000000000
--- a/media-gfx/ufraw/files/ufraw-0.22-CVE-2018-19655.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-Description: stack-based buffer overflow bug
-Bug-Debian: https://bugs.debian.org/890086
-Bug-Debian-Security: https://security-tracker.debian.org/tracker/CVE-2018-19655
-Author: Filip Hroch <hroch@physics.muni.cz>
-Reviewed-by: Salvatore Bonaccorso <carnil@debian.org>
-Last-Update: 2018-12-02
-
---- a/dcraw.cc
-+++ b/dcraw.cc
-@@ -8505,9 +8505,15 @@ float CLASS find_green (int bps, int bit
- {
- UINT64 bitbuf=0;
- int vbits, col, i, c;
-- ushort img[2][2064];
-+ ushort *img;
- double sum[]={0,0};
-
-+#define IMG2D(row,col) \
-+ img[(row)*width+(col)]
-+
-+ img = (ushort *) malloc(2*width*sizeof(ushort));
-+ merror (img, "find_green()");
-+
- FORC(2) {
- fseek (ifp, c ? off1:off0, SEEK_SET);
- for (vbits=col=0; col < width; col++) {
-@@ -8516,13 +8522,14 @@ float CLASS find_green (int bps, int bit
- for (i=0; i < bite; i+=8)
- bitbuf |= (unsigned) (fgetc(ifp) << i);
- }
-- img[c][col] = bitbuf << (64-bps-vbits) >> (64-bps);
-+ IMG2D(c,col) = bitbuf << (64-bps-vbits) >> (64-bps);
- }
- }
- FORC(width-1) {
-- sum[ c & 1] += ABS(img[0][c]-img[1][c+1]);
-- sum[~c & 1] += ABS(img[1][c]-img[0][c+1]);
-+ sum[ c & 1] += ABS(IMG2D(0,c)-IMG2D(1,c+1));
-+ sum[~c & 1] += ABS(IMG2D(1,c)-IMG2D(0,c+1));
- }
-+ free(img);
- return 100 * log(sum[0]/sum[1]);
- }
-
diff --git a/media-gfx/ufraw/files/ufraw-0.22-crashfix.patch b/media-gfx/ufraw/files/ufraw-0.22-crashfix.patch
deleted file mode 100644
index 76fe83fa8f2e..000000000000
--- a/media-gfx/ufraw/files/ufraw-0.22-crashfix.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/ufraw_ufraw.c 2015-06-16 04:58:38.000000000 +0100
-+++ b/ufraw_ufraw.c 2016-12-18 00:55:45.794466747 +0000
-@@ -767,8 +767,10 @@ void ufraw_close(ufraw_data *uf)
- g_free(uf->displayProfile);
- g_free(uf->RawHistogram);
- #ifdef HAVE_LENSFUN
-- lf_modifier_destroy(uf->TCAmodifier);
-- lf_modifier_destroy(uf->modifier);
-+ if (uf->TCAmodifier != NULL)
-+ lf_modifier_destroy(uf->TCAmodifier);
-+ if (uf->modifier != NULL)
-+ lf_modifier_destroy(uf->modifier);
- #endif
- ufobject_delete(uf->conf->ufobject);
- g_free(uf->conf);
diff --git a/media-gfx/ufraw/files/ufraw-0.22-drop_superfluous_abs.patch b/media-gfx/ufraw/files/ufraw-0.22-drop_superfluous_abs.patch
deleted file mode 100644
index 8c11f6649781..000000000000
--- a/media-gfx/ufraw/files/ufraw-0.22-drop_superfluous_abs.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Fixes build with gcc 7, by Johannes Hirte.
-https://bugs.gentoo.org/show_bug.cgi?id=618068
-
-diff --git a/../old/dcraw.cc b/dcraw.cc
-index 88c8068..cedf86b 100644
---- a/../old/dcraw.cc
-+++ b/dcraw.cc
-@@ -9242,7 +9242,7 @@ canon_a5:
- if (make[0] == 'O') {
- i = find_green (12, 32, 1188864, 3576832);
- c = find_green (12, 32, 2383920, 2387016);
-- if (abs(i) < abs(c)) {
-+ if (i < c) {
- SWAP(i,c);
- load_flags = 24;
- }
diff --git a/media-gfx/ufraw/files/ufraw-0.22-exiv2-0.27.patch b/media-gfx/ufraw/files/ufraw-0.22-exiv2-0.27.patch
deleted file mode 100644
index 2cd888ebc096..000000000000
--- a/media-gfx/ufraw/files/ufraw-0.22-exiv2-0.27.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- a/ufraw_exiv2.cc
-+++ b/ufraw_exiv2.cc
-@@ -15,9 +15,8 @@
- #include "ufraw.h"
-
- #ifdef HAVE_EXIV2
--#include <exiv2/image.hpp>
--#include <exiv2/easyaccess.hpp>
--#include <exiv2/exif.hpp>
-+#include <exiv2/exiv2.hpp>
-+#include <iostream>
- #include <sstream>
- #include <cassert>
-
-@@ -67,7 +66,11 @@ extern "C" int ufraw_exif_read_input(ufraw_data *uf)
- if (exifData.empty()) {
- std::string error(uf->filename);
- error += ": No Exif data found in the file";
-+#if EXIV2_TEST_VERSION(0,27,0)
-+ throw Exiv2::Error(Exiv2::kerErrorMessage, error);
-+#else
- throw Exiv2::Error(1, error);
-+#endif
- }
-
- /* List of tag names taken from exiv2's printSummary() in actions.cpp */
diff --git a/media-gfx/ufraw/files/ufraw-0.22-fix-unsigned-char.patch b/media-gfx/ufraw/files/ufraw-0.22-fix-unsigned-char.patch
deleted file mode 100644
index a5397260ffb5..000000000000
--- a/media-gfx/ufraw/files/ufraw-0.22-fix-unsigned-char.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Description: Fix unsigned char declaration of src[]
-Author: John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
-Last-Update: 2017-02-27
-
-https://bugs.gentoo.org/show_bug.cgi?id=622484
-https://sourceforge.net/p/ufraw/bugs/417/
-https://src.fedoraproject.org/cgit/rpms/ufraw.git/tree/05_fix_build_due_to_unsigned_char.patch
-https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=856227
-
---- ufraw-0.22.orig/dcraw.cc
-+++ ufraw-0.22/dcraw.cc
-@@ -2285,7 +2285,7 @@ void CLASS quicktake_100_load_raw()
-
- void CLASS kodak_radc_load_raw()
- {
-- static const char src[] = {
-+ static const signed char src[] = {
- 1,1, 2,3, 3,4, 4,2, 5,7, 6,5, 7,6, 7,8,
- 1,0, 2,1, 3,3, 4,4, 5,2, 6,7, 7,6, 8,5, 8,8,
- 2,1, 2,3, 3,0, 3,2, 3,4, 4,6, 5,5, 6,7, 6,8,
diff --git a/media-gfx/ufraw/files/ufraw-0.22-gcc9.patch b/media-gfx/ufraw/files/ufraw-0.22-gcc9.patch
deleted file mode 100644
index f2cf1dc88a86..000000000000
--- a/media-gfx/ufraw/files/ufraw-0.22-gcc9.patch
+++ /dev/null
@@ -1,97 +0,0 @@
-From ac8c74699cba65d65f918b3f4cba2de64e039ada Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?S=C3=A9rgio=20M=2E=20Basto?= <sergio@serjux.com>
-Date: Thu, 14 Feb 2019 03:26:02 +0000
-Subject: [PATCH] Fix GCC 9 OpenMP issues by drop default(none)
-
----
- dcraw_api.cc | 4 ++--
- dcraw_indi.c | 4 ----
- ufraw_ufraw.c | 6 +++---
- 3 files changed, 5 insertions(+), 9 deletions(-)
-
-diff --git a/dcraw_api.cc b/dcraw_api.cc
-index c3d2902..6096cb7 100644
---- a/dcraw_api.cc
-+++ b/dcraw_api.cc
-@@ -686,7 +686,7 @@ extern "C" {
- rgbWB[3] = rgbWB[1];
- if (dark) {
- #ifdef _OPENMP
-- #pragma omp parallel for schedule(static) default(none) \
-+ #pragma omp parallel for schedule(static) \
- shared(h,dark,rgbWB)
- #endif
- for (int i = 0; i < pixels; i++) {
-@@ -699,7 +699,7 @@ extern "C" {
- }
- } else {
- #ifdef _OPENMP
-- #pragma omp parallel for schedule(static) default(none) \
-+ #pragma omp parallel for schedule(static) \
- shared(h,dark,rgbWB)
- #endif
- for (int i = 0; i < pixels; i++) {
-diff --git a/dcraw_indi.c b/dcraw_indi.c
-index a291af2..777ce39 100644
---- a/dcraw_indi.c
-+++ b/dcraw_indi.c
-@@ -137,12 +137,10 @@ void CLASS wavelet_denoise_INDI(ushort(*image)[4], const int black,
- #ifdef _OPENMP
- #if defined(__sun) && !defined(__GNUC__) /* Fix bug #3205673 - NKBJ */
- #pragma omp parallel for \
-- default(none) \
- shared(nc,image,size,noise) \
- private(c,i,hpass,lev,lpass,row,col,thold,fimg,temp)
- #else
- #pragma omp parallel for \
-- default(none) \
- shared(nc,image,size) \
- private(c,i,hpass,lev,lpass,row,col,thold,fimg,temp)
- #endif
-@@ -413,7 +411,6 @@ void CLASS vng_interpolate_INDI(ushort(*image)[4], const unsigned filters,
- progress(PROGRESS_INTERPOLATE, -height);
- #ifdef _OPENMP
- #pragma omp parallel \
-- default(none) \
- shared(image,code,prow,pcol,h) \
- private(row,col,g,brow,rowtmp,pix,ip,gval,diff,gmin,gmax,thold,sum,color,num,c,t)
- #endif
-@@ -496,7 +493,6 @@ void CLASS ppg_interpolate_INDI(ushort(*image)[4], const unsigned filters,
-
- #ifdef _OPENMP
- #pragma omp parallel \
-- default(none) \
- shared(image,dir,diff) \
- private(row,col,i,d,c,pix,guess)
- #endif
-diff --git a/ufraw_ufraw.c b/ufraw_ufraw.c
-index ce9d262..48a0d91 100644
---- a/ufraw_ufraw.c
-+++ b/ufraw_ufraw.c
-@@ -1043,7 +1043,7 @@ static void ufraw_shave_hotpixels(ufraw_data *uf, dcraw_image_type *img,
- delta = rgbMax / (uf->conf->hotpixel + 1.0);
- count = 0;
- #ifdef _OPENMP
-- #pragma omp parallel for schedule(static) default(none) \
-+ #pragma omp parallel for schedule(static) \
- shared(uf,img,width,height,colors,rgbMax,delta) \
- reduction(+:count) \
- private(h,p,w,c,t,v,hi,i)
-@@ -1365,7 +1365,7 @@ static void ufraw_convert_reverse_wb(ufraw_data *uf, UFRawPhase phase)
- mul[i] = (guint64)0x10000 * 0x10000 / uf->developer->rgbWB[i];
- size = img->height * img->width;
- #ifdef _OPENMP
-- #pragma omp parallel for schedule(static) default(none) \
-+ #pragma omp parallel for schedule(static) \
- shared(uf,phase,img,mul,size) \
- private(i,p16,c,px)
- #endif
-@@ -1390,7 +1390,7 @@ static void ufraw_convert_image_tca(ufraw_data *uf, ufraw_image_data *img,
- return;
- int y;
- #ifdef _OPENMP
-- #pragma omp parallel for schedule(static) default(none) \
-+ #pragma omp parallel for schedule(static) \
- shared(uf,img,outimg,area)
- #endif
- for (y = area->y; y < area->y + area->height; y++) {
diff --git a/media-gfx/ufraw/files/ufraw-0.22-glib-2.68.patch b/media-gfx/ufraw/files/ufraw-0.22-glib-2.68.patch
deleted file mode 100644
index c2499fa16bf5..000000000000
--- a/media-gfx/ufraw/files/ufraw-0.22-glib-2.68.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/uf_glib.h 2021-04-18 23:14:11.346861061 -0400
-+++ b/uf_glib.h 2021-04-18 23:14:20.180520873 -0400
-@@ -13,13 +13,13 @@
- #ifndef _UF_GLIB_H
- #define _UF_GLIB_H
-
-+#include <glib.h>
-+#include <glib/gstdio.h>
-+
- #ifdef __cplusplus
- extern "C" {
- #endif
-
--#include <glib.h>
--#include <glib/gstdio.h>
--
- // g_win32_locale_filename_from_utf8 is needed only on win32
- #ifdef _WIN32
- #define uf_win32_locale_filename_from_utf8(__some_string__) \
diff --git a/media-gfx/ufraw/files/ufraw-0.22-jasper-automagic.patch b/media-gfx/ufraw/files/ufraw-0.22-jasper-automagic.patch
deleted file mode 100644
index 93e1d691af1d..000000000000
--- a/media-gfx/ufraw/files/ufraw-0.22-jasper-automagic.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -159,8 +159,16 @@
- have_jpeg=${ac_cv_lib_jpeg_jpeg_CreateCompress:-no}
-
- # Check for libjasper.
--AC_CHECK_LIB(jasper, jas_image_decode)
--have_jasper=${ac_cv_lib_jasper_jas_image_decode:-no}
-+AC_ARG_ENABLE([jasper],
-+ AS_HELP_STRING([--enable-jasper], [enable JPEG2000 support]))
-+
-+have_jasper=no
-+AS_IF([test "x$enable_jasper" = "xyes"], [
-+ AC_SEARCH_LIBS([jas_image_decode], [jasper], [have_jasper=yes], [
-+ AC_MSG_ERROR([unable to find the jas_image_decode() function])
-+ ])
-+])
-+
-
- # Check for tiff headers and library.
- PKG_CHECK_MODULES(LIBTIFF, libtiff-4,
diff --git a/media-gfx/ufraw/files/ufraw-0.22-jpeg9.patch b/media-gfx/ufraw/files/ufraw-0.22-jpeg9.patch
deleted file mode 100644
index dca3834cbe8e..000000000000
--- a/media-gfx/ufraw/files/ufraw-0.22-jpeg9.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Fix build with >=jpeg-9
-Thanks-to: Moran Z. <o542018138@gmail.com>
-
---- a/dcraw.cc 2014-09-02 07:50:38.000000000 +0300
-+++ b/dcraw.cc 2015-02-21 04:54:13.957561352 +0200
-@@ -2330,7 +2330,7 @@
- #endif
- cinfo->src->next_input_byte = jpeg_buffer;
- cinfo->src->bytes_in_buffer = nbytes;
-- return TRUE;
-+ return boolean(TRUE);
- }
-
- void CLASS kodak_jpeg_load_raw()
-@@ -2346,7 +2346,7 @@
- jpeg_create_decompress (&cinfo);
- jpeg_stdio_src (&cinfo, ifp);
- cinfo.src->fill_input_buffer = fill_input_buffer;
-- jpeg_read_header (&cinfo, TRUE);
-+ jpeg_read_header (&cinfo, boolean(TRUE));
- jpeg_start_decompress (&cinfo);
- if ((cinfo.output_width != width ) ||
- (cinfo.output_height*2 != height ) ||
-@@ -2419,7 +2419,7 @@
- if (tile_length < INT_MAX)
- fseek (ifp, get4(), SEEK_SET);
- jpeg_stdio_src (&cinfo, ifp);
-- jpeg_read_header (&cinfo, TRUE);
-+ jpeg_read_header (&cinfo, boolean(TRUE));
- jpeg_start_decompress (&cinfo);
- buf = (*cinfo.mem->alloc_sarray)
- ((j_common_ptr) &cinfo, JPOOL_IMAGE, cinfo.output_width*3, 1);