summaryrefslogtreecommitdiff
path: root/media-gfx/shotwell
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/shotwell')
-rw-r--r--media-gfx/shotwell/Manifest2
-rw-r--r--media-gfx/shotwell/shotwell-0.30.14.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
index 18ea533a94dc..95fcdf95b393 100644
--- a/media-gfx/shotwell/Manifest
+++ b/media-gfx/shotwell/Manifest
@@ -1,3 +1,5 @@
DIST shotwell-0.30.12.tar.xz 6519996 BLAKE2B 7417f1bf0057b4974b45be675b177f6fba232d60d56c3d98cc6d5a7a95a31281add5190a04eab965739759aa7d826515996f2fd62350352a54ebf969dc732d95 SHA512 3274f15969be7f75ad2fa44e78773b76e11ee6cf8d4990c7f658fa8ce7e84a8fa5f06542fbab4b585c70e41c097c7b07ba702540102e4d0dfca8e927e00180cf
+DIST shotwell-0.30.14.tar.xz 6524680 BLAKE2B 321406d3731a4baa333c3820ee46e8dc12ca9a340c7f1ac3824ee894fa2826b7efa3ee7a27f551d62043e5f22199042befb5063cc67cefd27830e19db7d7f661 SHA512 bd899ac099ec4760f6119804812ef9314c9261c18273309abfb1dccc675b9e4a561c0abea1c46ea0dbbab9f5c00301d840b52714f97ec06548c180a77871db7c
EBUILD shotwell-0.30.12.ebuild 1769 BLAKE2B ce81642084c5b8ac1b41b72842ac4c798ab3a2a136e95f899735bd4dbab8d013809c1a0b6139f366b2f0e6a76d7a26a314b80ea453405e2a2f4eb1dbfd2e5d3a SHA512 e8aab87360f510ee71ae3b06f9904a7895223ea31ec1b7a5e29f9f8238668e523d5654bad84c4f459fdad78cc6853f4478994c2383535b834c342a4c6469e081
+EBUILD shotwell-0.30.14.ebuild 1771 BLAKE2B 301664fc4c7ee4412d7f026ecb18a0acba139aeca6b84c64d2f76fb9f3d86b8fe421369a47cbf8f706e6961cbb1785ec3dbc7577363c2f193efdff459a52f572 SHA512 788ac87b1fc37afb3e14848279311be0886093559fde326ca738e2421dafe0e1394977309fe752ff014156ac914e6ae8716569d3f5e8e55b8a84f54a9ddec296
MISC metadata.xml 795 BLAKE2B 4b5da2cc205b128a0cb9d10a50c3743b8d12302d266e37d5e0479915824af75af8c22b7b12ffca57146aa0a999e2bff3d7c4969af9e19f317a70b9195b02333f SHA512 d3ceceeed90fd4cadd5e212d047b3d6f7882860d145cb80521a4db8e9baaf461910ff70cb5bb2c1cda991939bf2c8917bb7f252bf68c7487d40271b0419c6322
diff --git a/media-gfx/shotwell/shotwell-0.30.14.ebuild b/media-gfx/shotwell/shotwell-0.30.14.ebuild
new file mode 100644
index 000000000000..3397e5e68673
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.30.14.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Shotwell"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~sparc ~x86"
+IUSE="opencv udev"
+
+DEPEND="
+ >=x11-libs/gtk+-3.22.0:3
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libgee-0.8.5:0.8
+ >=net-libs/webkit-gtk-2.26:4
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libxml2-2.6.32:2
+ x11-libs/gdk-pixbuf:2
+ >=dev-db/sqlite-3.5.9:3
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ >=media-libs/libgphoto2-2.5:=
+ udev? ( >=dev-libs/libgudev-145:= )
+ >=media-libs/gexiv2-0.10.4
+ >=media-libs/libraw-0.13.2:=
+ >=media-libs/libexif-0.6.16:=
+ dev-libs/libgdata
+ >=app-crypt/gcr-3:=[gtk]
+ x11-libs/cairo
+ opencv? ( >=media-libs/opencv-2.3.0:= )
+"
+RDEPEND="${DEPEND}
+ media-plugins/gst-plugins-gdkpixbuf:1.0
+ media-plugins/gst-plugins-meta:1.0
+"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ net-libs/libsoup:2.4[vala]
+ media-libs/gexiv2[vala]
+ app-crypt/gcr[vala]
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dunity-support=false
+ # -Dpublishers # In 0.30.2 all get compiled in anyways, even if restricted list, affects only runtime support
+ -Dextra-plugins=true
+ #trace
+ #measure
+ -Ddupe-detection=true
+ $(meson_use udev)
+ -Dinstall-apport-hook=false
+ $(meson_use opencv face-detection)
+ -Dfatal_warnings=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}