summaryrefslogtreecommitdiff
path: root/media-gfx/ristretto
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/ristretto')
-rw-r--r--media-gfx/ristretto/Manifest2
-rw-r--r--media-gfx/ristretto/ristretto-0.8.5.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/media-gfx/ristretto/Manifest b/media-gfx/ristretto/Manifest
index 4182bb9c9723..1d7cabd03e2b 100644
--- a/media-gfx/ristretto/Manifest
+++ b/media-gfx/ristretto/Manifest
@@ -1,3 +1,5 @@
DIST ristretto-0.8.4.tar.bz2 581374 BLAKE2B 8d4dc91daa1aebf7d8193d8a48c3be29ad6fed86b7fbea68effb63f6a56d2d39898b5ab0c93933adf9d65cce327109dca5ecff96855c4311494de7cc4182213f SHA512 c5479cde66e4f0903b9b8d9b1b8f4c7cde35ebfa334e414c8202e783c332bd4bfec650f85d308c7151d31fe84b27a13bb4048290b0a82ce7b8ba4baf3e4088b8
+DIST ristretto-0.8.5.tar.bz2 583736 BLAKE2B b2c0582eb7930eb3bdf9941dc086befd6a81f0d3aa8ea5ecdbedb00f7914287937e520c5257853d080dca4ebee08f1c40f8e8386a6de90856721a804462e9cab SHA512 48d2a68cd13e58c0f450fc674b031a4fc4495ece0ae00805f0564a5bd9cc2ac19c1c009726dd343bdfeffa59509f0ecc9cd069986af5a2ff2c2566c4490b5fbf
EBUILD ristretto-0.8.4.ebuild 876 BLAKE2B c950d825ab3ba23f9a0660a45c18874d591271a86e03c32d77be2908af0628cd1936290505f03a3b523ffd8932a453a8467d5c37062b6e19800635b8835c812f SHA512 42a4b7741c85d52878adc859fe4b9c9a7c5680c59be2c9c52bc9768371c2f39b89da1f01130c63aa4e66420b7d637531355c9eaea418d761b80024bfceb8c337
+EBUILD ristretto-0.8.5.ebuild 859 BLAKE2B f78523b7231cc1539b258c3fefa5087702c85859c456d7bd3200c5edbb194deda98d7ba0fa3e5bed4ee37461f5990a7f77db5e68b6cc86724fc298317e6a302e SHA512 0a9dcd229aebc553cf39dc4b349b737eea6d30941e60b05c4c8236cba84de6af4532f26a9bd1f77b39d7dafdb25f7a7b6b596226f0191e2ab73eb684f6495e70
MISC metadata.xml 247 BLAKE2B f381ffd75f3fdb2842002ea885015f443cc35334f0420d70a61d6730bd55c11750d6a177831dc7c8564eec4dc3863db6085162e58848b0dceb09799006a1b2c5 SHA512 25494c0053fb7b2ed0f78ecc2de8a8ae08a971db8e15f89e906a1d43177fef53eb9ec5dd075a5c67ddee2be112c0943f6c87e4870d405436bddfea3a4fa19203
diff --git a/media-gfx/ristretto/ristretto-0.8.5.ebuild b/media-gfx/ristretto/ristretto-0.8.5.ebuild
new file mode 100644
index 000000000000..f41ef692e684
--- /dev/null
+++ b/media-gfx/ristretto/ristretto-0.8.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A fast and lightweight picture viewer for Xfce"
+HOMEPAGE="https://docs.xfce.org/apps/ristretto/start"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.24:2
+ media-libs/libexif:0=
+ x11-libs/cairo:0
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11:0=
+ >=xfce-base/libxfce4ui-4.10:0=
+ >=xfce-base/libxfce4util-4.10:0=
+ >=xfce-base/xfconf-4.10:0="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}