summaryrefslogtreecommitdiff
path: root/media-gfx/rawtherapee
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/rawtherapee')
-rw-r--r--media-gfx/rawtherapee/Manifest5
-rw-r--r--media-gfx/rawtherapee/rawtherapee-5.7.ebuild72
2 files changed, 77 insertions, 0 deletions
diff --git a/media-gfx/rawtherapee/Manifest b/media-gfx/rawtherapee/Manifest
index 95b4444a1b86..23792288e8b8 100644
--- a/media-gfx/rawtherapee/Manifest
+++ b/media-gfx/rawtherapee/Manifest
@@ -1,3 +1,8 @@
DIST rawtherapee-5.6.tar.xz 12083264 BLAKE2B a0eb09e98e1041b393ad3aa671641a2a4855379cef6245ca3cca2588ff5f50fedf8becd88bad1ab70f63dfb575f5f22c141040defa10b47268947415999d8e79 SHA512 2c751c7631ea2ef65c334fa0baab16d4c3161fae66487870c476f07f1ea3604a5e28a251fd98d9688cafc088302af7aa6e28e9b27a37f916715708ed5e731f0f
+<<<<<<< HEAD
+=======
+DIST rawtherapee-5.7.tar.xz 12092496 BLAKE2B 40d97d09106d7d2b843376b4c58daac87f99315604bd8e704e1f231c17d01896cd732da2449f84a59ed221fbf6a929a5db8e728977431fdcc07f3d30120b633a SHA512 8101ec66d9be4cab0c0b91336a3f83a32a6220a2f342f1c74d604c15686ee08bc7dbc090232916f13d5436957d800b64b284a8a9d3352f2f721266b07e005162
+>>>>>>> next
EBUILD rawtherapee-5.6.ebuild 1621 BLAKE2B 9f963fabf47cc479f8b840648b227058c232cfaeefc8904fe2ae2ee38e4b219b427633b8575ffd27172bc49c0fc4c99973e55e193883bc1f6fb35f0176d19e2e SHA512 557b60056ab12fb8b9dea4702e7fae0d2438abc89a5f414d75cdd353ee7a99ea6cbafc4df118ad7272c880dfc0f1a107a4ffff190e9a317b75de68471c15a336
+EBUILD rawtherapee-5.7.ebuild 1623 BLAKE2B bf3e2d94b876c48aeedcbb2030d282753a78da2a4c905b5565446ede991e854277fb2ccd99f409d52ccdb5df986f50525cccaf42e0b1124f68a22c0ca7311865 SHA512 4aeee80c36f123d97d55ff343dc326428f597f74d282f1186cbb9255d0ef2f29dab7ad56cb886e7b20dcbe1353a1988ff205b7d2cc3fc2c1580bbf18b8c6d8c4
MISC metadata.xml 484 BLAKE2B 672746e8291016ad6467a9b3c9baa84abac42df9f7de4b4bdb79374bba8e84f7cbfe140a076ebee49ec50587154612b73c6a7022461d01fd7fbdc63a6ddfcd98 SHA512 91f11609c7472bb7cebff5d440ee3d4b0560e0832e1bfb6ffd5b239e8e60647e067894d77ccb6e40a379680775f80b91250c3feab5cd2ce32d7991e0776d0cd9
diff --git a/media-gfx/rawtherapee/rawtherapee-5.7.ebuild b/media-gfx/rawtherapee/rawtherapee-5.7.ebuild
new file mode 100644
index 000000000000..48b8dca754d1
--- /dev/null
+++ b/media-gfx/rawtherapee/rawtherapee-5.7.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${P/_rc/-rc}
+inherit cmake-utils flag-o-matic toolchain-funcs xdg-utils
+
+DESCRIPTION="A powerful cross-platform raw image processing program"
+HOMEPAGE="https://www.rawtherapee.com/"
+SRC_URI="https://rawtherapee.com/shared/source/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="openmp"
+
+RDEPEND="
+ dev-libs/expat
+ dev-libs/libsigc++:2
+ media-libs/lcms:2
+ media-libs/lensfun
+ media-libs/libcanberra[gtk3]
+ media-libs/libiptcdata
+ media-libs/libpng:0
+ media-libs/tiff:0
+ sci-libs/fftw:3.0
+ sys-libs/zlib
+ virtual/jpeg:0
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ dev-cpp/gtkmm:3.0
+ gnome-base/librsvg"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}
+
+src_configure() {
+ # upstream tested that "fast-math" give wrong results, so filter it
+ # https://bugs.gentoo.org/show_bug.cgi?id=606896#c2
+ filter-flags -ffast-math
+ # -Ofast enable "fast-math" both in gcc and clang
+ replace-flags -Ofast -O3
+ # In case we add an ebuild for klt we can (i)use that one,
+ # see http://cecas.clemson.edu/~stb/klt/
+ local mycmakeargs=(
+ -DOPTION_OMP=$(usex openmp)
+ -DDOCDIR=/usr/share/doc/${PF}
+ -DCREDITSDIR=/usr/share/${PN}
+ -DLICENCEDIR=/usr/share/${PN}
+ -DCACHE_NAME_SUFFIX=""
+ -DWITH_SYSTEM_KLT="off"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}