summaryrefslogtreecommitdiff
path: root/media-gfx/pixie/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pixie/files')
-rw-r--r--media-gfx/pixie/files/Makefile.shaders15
-rw-r--r--media-gfx/pixie/files/pixie-2.2.6-autotools.patch22
-rw-r--r--media-gfx/pixie/files/pixie-2.2.6-zlib-1.2.5.2.patch73
3 files changed, 0 insertions, 110 deletions
diff --git a/media-gfx/pixie/files/Makefile.shaders b/media-gfx/pixie/files/Makefile.shaders
deleted file mode 100644
index fbc261c0c9bf..000000000000
--- a/media-gfx/pixie/files/Makefile.shaders
+++ /dev/null
@@ -1,15 +0,0 @@
-SDRC = ../src/sdrc/sdrc
-SDRCFLAGS +=
-
-%.sdr: %.sl
- $(SDRC) $(SDRCFLAGS) $<
-
-OBJECT1 := $(wildcard *.sl)
-OBJECT := $(OBJECT1:.sl=.sdr)
-
-all: clean $(OBJECT)
-
-clean:
- rm -f *.sdr
-
-.PHONY: clean
diff --git a/media-gfx/pixie/files/pixie-2.2.6-autotools.patch b/media-gfx/pixie/files/pixie-2.2.6-autotools.patch
deleted file mode 100644
index 7fd9f0ce76b0..000000000000
--- a/media-gfx/pixie/files/pixie-2.2.6-autotools.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/src/ri/Makefile.in 2009-09-23 18:10:13.414866323 +0200
-+++ b/src/ri/Makefile.in 2009-09-23 18:11:15.629864395 +0200
-@@ -214,7 +214,7 @@
- host_os = @host_os@
- host_vendor = @host_vendor@
- htmldir = @htmldir@
--includedir = $(prefix)/include
-+includedir = @includedir@
- infodir = @infodir@
- install_sh = @install_sh@
- libdir = @libdir@
---- a/src/sdr/Makefile.in 2009-09-23 18:14:54.194865868 +0200
-+++ b/src/sdr/Makefile.in 2009-09-23 18:15:18.297863856 +0200
-@@ -199,7 +199,7 @@
- host_os = @host_os@
- host_vendor = @host_vendor@
- htmldir = @htmldir@
--includedir = $(prefix)/include
-+includedir = @includedir@
- infodir = @infodir@
- install_sh = @install_sh@
- libdir = @libdir@
diff --git a/media-gfx/pixie/files/pixie-2.2.6-zlib-1.2.5.2.patch b/media-gfx/pixie/files/pixie-2.2.6-zlib-1.2.5.2.patch
deleted file mode 100644
index 7e0afe3a7c27..000000000000
--- a/media-gfx/pixie/files/pixie-2.2.6-zlib-1.2.5.2.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-http://bugs.gentoo.org/406899
-
---- a/src/ri/rib.l
-+++ b/src/ri/rib.l
-@@ -17,7 +17,7 @@
-
- // Overwrite the YYinput so that it uses libz
- #undef YY_INPUT
--#define YY_INPUT(buf, retval, maxlen) if ( (retval = gzread(ribin,buf,maxlen)) < 0) \
-+#define YY_INPUT(buf, retval, maxlen) if ( (retval = gzread((gzFile)ribin,buf,maxlen)) < 0) \
- YY_FATAL_ERROR( "input in flex scanner failed" );
-
- #endif
-@@ -223,7 +223,7 @@
- TRibFile *nextFile = ribStack->next;
- rib_delete_buffer( YY_CURRENT_BUFFER );
- #ifdef HAVE_ZLIB
-- gzclose(ribin);
-+ gzclose((gzFile)ribin);
- #else
- fclose(ribin);
- #endif
-@@ -243,7 +243,7 @@
- rib_delete_buffer( YY_CURRENT_BUFFER );
-
- #ifdef HAVE_ZLIB
-- gzclose(ribin);
-+ gzclose((gzFile)ribin);
- #else
- fclose(ribin);
- #endif
---- a/src/ri/ribOut.cpp
-+++ b/src/ri/ribOut.cpp
-@@ -162,7 +162,7 @@
-
- #ifdef HAVE_ZLIB
- if (outputCompressed) {
-- gzclose(outFile);
-+ gzclose((gzFile)outFile);
- } else {
- fclose(outFile);
- }
---- a/src/ri/ribOut.h
-+++ b/src/ri/ribOut.h
-@@ -237,7 +237,7 @@
- const int l = vsprintf(scratch,mes,args);
-
- #ifdef HAVE_ZLIB
-- if (outputCompressed) gzwrite(outFile,scratch,l);
-+ if (outputCompressed) gzwrite((gzFile)outFile,scratch,l);
- else fwrite(scratch,1,l,outFile);
- #else
- fwrite(scratch,1,l,outFile);
-@@ -258,7 +258,7 @@
- const int l = vsprintf(scratch,mes,args);
-
- #ifdef HAVE_ZLIB
-- if (outputCompressed) gzwrite(outFile,scratch,l);
-+ if (outputCompressed) gzwrite((gzFile)outFile,scratch,l);
- else fwrite(scratch,1,l,outFile);
- #else
- fwrite(scratch,1,l,outFile);
---- a/src/ri/rib.y
-+++ b/src/ri/rib.y
-@@ -2940,7 +2940,7 @@
-
- if (ribin != NULL) {
- #ifdef HAVE_ZLIB
-- gzclose(ribin);
-+ gzclose((gzFile)ribin);
- #else
- fclose(ribin);
- #endif